Inpho

Ctrl+T doesn't tidy anymore - any idea how to fix it?

11 posts in this topic

It randomly started out of nowhere. Nothing changed since last weekend and now it's just not working. No idea what I've done.

I've reinstalled AutoIt and SciTE fully, didn't help. I've been here and here, no help.

Can anyone point out where in the SciTE help file it explains these commands? I've been through it and there seems to be no explanation. Or where I could find a relevant IFaceTable.cxx file?

I just want to re-enable ctrl-t for tidy, why is this so hard? xD

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Show me the full output information of the SciTE outputpane when doing Crtl+T

In case nothing is shown, you need to start figuring out which application you installed that could be snooping this shortcut. 
You could also test to change the the shortcut to ensure Tidy works.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Thanks for the reply.

Nothing happens in the console when pressed, it just swaps the current selected line with the line above. How do I change the shortcut?

Edited by Inpho

Share this post


Link to post
Share on other sites

Sounds like you do not have the separate full SciTE4AutoIt3 installer installed as that is the default transpose option. 

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

As stated in the first post, i have fully reinstalled Scite (AutoIt Script Editor from here).

How do I change the shortcut?

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

That is a link to the AutoIt3 installer which includes the lite version of SciTE. Use the link in my signature for the full version.

Do you see the Tidy option under Tools? 
You do have a file open with an au3 extension ..right?

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Jos are you telling me that the link in the red square is NOT the full version of SciTE? Because this is what I have downloaded, as I said.

 

dsa.jpg

Share this post


Link to post
Share on other sites

Already corrected my post ...  check one post up .... ;)
Aslo let me know the info for SciTE - Help- About SciTE

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#9 ·  Posted (edited)

There isn't an option for Tidy under tools, which is strange. Yes it's a .au3

Title bar says SciTE, not SciTE Lite

Version 3.6.2

Edited by Inpho

Share this post


Link to post
Share on other sites

Sorted, I needed to run the script C:\Program Files (x86)\AutoIt3\SciTE\SciTEConfig\SciteConfig.au3, then in Tools tab, enabled "Jos's Tidy formatting program for Autiit3" and all is fine. I've got no idea how this option changed in the first place, but there's the fix.

Thanks for your time Jos

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now