Sign in to follow this  
Followers 0
sadman13

Java deployment

5 posts in this topic

$USERNAME = "xxxxx"

$DOMAIN = "xx"

$PASSWORD = "xxxxxx"

RunAsSet($USERNAME, $DOMAIN, $PASSWORD)

DriveMapAdd("X:", "\\ridist01\softdist")

sleep(5000)

;RunWait("x:\java.bat")

DriveMapDel( "X:" )

RunAsSet()

When running auto script above error - cannot execute external program

drive maps and deletes ok but bat file will not run

if bat file manually run through mapped drive it runs and installs java ok

Share this post


Link to post
Share on other sites



If it was the comment stopping you... then B)

You could always debug, if you were commenting to see if it was creating and logging you off.

DriveMapAdd("X:", "\\ridist01\softdist")
Sleep(5000)
DriveMapGet("X:")
If @error Then
    MsgBox(0, 'Error', 'Error reading Drive')
Else
    If FileExists("x:\java.dat") Then
        RunWait("x:\java.bat")
        DriveMapDel( "X:")
    Else
        MsgBox(0, 'Error', 'File java.dat does not exist')
    EndIf
EndIf

[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

the commenting out was a mistake it was taken out to test the drive mapping which works fine.

even though the drives map ok the error -

unable to execute the external program - the system cannot find the path specified

every time the compiled script is called from our login kix script

we tried your error logging and it comes back with no error for the drive map but comes back with the error

error: unable to execute the external program - the system cannot find the path specified

help is much appreciated

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

the commenting out was a mistake it was taken out to test the drive mapping which works fine.

even though the drives map ok the error -

unable to execute the external program - the system cannot find the path specified

every time the compiled script is called from our login kix script

we tried your error logging and it comes back with no error for the drive map but comes back with the error

error: unable to execute the external program - the system cannot find the path specified

help is much appreciated

I've had much trouble trying to have login scripts see anything outside of their default folder. It's been almost impossible for us to map to another PC/Server during that login session, even with a runasset function. Edited by blademonkey

---"Educate the Mind, Make Savage the Body" -Mao Tse Tung

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0