Jump to content

windows service print file

Recommended Posts




i'm new to this forum, so i'm not sure if it is the right thread for this.

thank you for all the answers.


here is my issue:

i created a windows service that runs an exe file. 

the code does some stuff, but somewhere in there i also want to do a print of a file.

if i run the exe file with the right click and run as administrator, it works fine, but if i run it through a windows service, it doesn't.  everything else is done except printing of a file. i also tried without UAC, just to be sure if it has something to do with it. it doesn't.

i'm printing a pdf file, so i'm using acrobat reader as a default. does it have to do something with the version? i checked the task manager, and acrobat reader is opened and closed as it should be when run through a win service.

when run as "run as admin.." it also opens in the task manager, but also opens/closes the file. so i can actually see the file.

the service is run by a local administrator, the same one that does "run as administrator" stuff.


thank you


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.