Jump to content
Sign in to follow this  

Bug with line continuation and comments in

Recommended Posts



Has anyone else had any problems with comments after a line continuation character. When I run the sample code from the latest beta help

dim $b_; This _ is not a continuation character, nor is the next one
dim $k_
Dim $a[8][2] = [ _
[ "Word", 4 ], _; Comment 1
[ "Test", 3 ], _
[ "pi", 3.14159], _; Associate the name with the value
[ "e", 2.718281828465], _; Same here
[ "test;1;2;3", 123], _
[ ';', Asc(';') ], _; This comment is removed, but the strings remain.
["", 0] ]

I get this:

>"C:\Program Files\AutoIt3\SciTe\CompileAU3\CompileAU3.exe" /run /beta /ErrorStdOut /in "C:\Documents and Settings\Anton\My Documents\AutoIt Scripts\SQLite\sqlite\temp.au3" /autoit3dir "C:\Program Files\AutoIt3\beta" /UserParams

>Running AU3Check...C:\Program Files\AutoIt3\SciTe\Defs\Unstable\Au3Check\au3check.dat

C:\Documents and Settings\Anton\My Documents\AutoIt Scripts\SQLite\sqlite\temp.au3(4,16) : ERROR: syntax error

[ "Word", 4 ], _


C:\Documents and Settings\Anton\My Documents\AutoIt Scripts\SQLite\sqlite\temp.au3(5,13) : ERROR: wrong nesting in initializer

[ "Test", 3 ]


C:\Documents and Settings\Anton\My Documents\AutoIt Scripts\SQLite\sqlite\temp.au3(6,1) : ERROR: syntax error



C:\Documents and Settings\Anton\My Documents\AutoIt Scripts\SQLite\sqlite\temp.au3 - 3 error(s), 0 warning(s)

>AU3Check Ended with Error(s).

>Exit code: 0 Time: 4.576

However, if I remove the comments it runs fine!

Is this a bug?



Share this post

Link to post
Share on other sites

Runs fine using and Scite.

>"C:\Program Files\AutoIt3\SciTe\CompileAU3\CompileAU3.exe" /run /beta /ErrorStdOut /in "C:\Documents and Settings\Admin\Desktop\test.au3" /autoit3dir "C:\Program Files\AutoIt3\beta" /UserParams

>Running AU3Check...C:\Program Files\AutoIt3\SciTe\Defs\Unstable\Au3Check\au3check.dat

>AU3Check Ended. No Error(s).

>Running: (\Program Files\AutoIt3\beta\autoit3.exe "C:\Documents and Settings\Admin\Desktop\test.au3"

>AutoIT3.exe ended.

>Exit code: 0 Time: 2.590

Share this post

Link to post
Share on other sites

It is AU3Check which generates the error so that means you haven't kept up-to-date B)

Download the latest SciTE4AutoIt3 and all should be fine....

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
Live for the present,
Dream of the future,
Learn from the past.

Share this post

Link to post
Share on other sites

I cannot reproduce it.

Are you sure you get the right Scite intallation?

Share this post

Link to post
Share on other sites

I think they didn't saw the latest beta-publishing ( where this bug was solved.

The beta is not publishing about Scite B)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.