DBuerger

Issues Running msiexec with Service_Arguments

2 posts in this topic

I'm having issues running an MSI with Service_Arguments.  If I run ShellExecuteWait('msiexec', $parameters1) it runs, but with running with $parameters0 it just pops up the MSI Windows Installer help window.  Any help is appreciated, code below and thanks in advanced!

$msi = @ScriptDir & "\ScreenConnect.ClientSetup.msi"
$name = $NamePart1 & " " & $Server & " " & $NamePart3
msgbox(0,'',$name)
$parameters0 = '/i "ScreenConnect.ClientSetup.msi" SERVICE_ARGUMENTS="?e=Access&y=Guest&h=screenconnect.sagesystem.com&p=8041&k=BgIAAACkAABSU0ExAAgAAAEAAQD%%2fVDhCLqj7LMgYl33xdWHbd%%2f7HE%%2b4auJrDTCCXpL7voDDmPHfn%%2ffOiqj5us%%2b1Nx8CMcVYAI00Taw4LuOere1udAB0UeJSxILJTL4HYYzdMy%%2fFsbNU9tPqfPfBp4YGShBIe5ejL7hnE7c31nrotgphuFyvx4vEvucjbLDUwhGreeXjOWAmNc7lCglingMY%%2fWjqOgjknVoM3O2jTjTkbfJXZgEHrinFfxdPcX4nmj5uP8dwG5kCg3bvVXjutP6OR5ESmfq56Bt%%2bj6M%%2bCULH8JeO7SjJF1baE5GMpewjuAJr6bM4WOVT7j0TSKKfsAvV4pgw33U3MwdMtO1YjLYfh%%2fUOx&t=%"'&$name&'"%&c=%"'&$CustomProperty1&'"%&c=&c=&c=&c=&c=&c=&c=" /qb'
$parameters1 = '/i "ScreenConnect.ClientSetup.msi"'
ShellExecuteWait('msiexec', $parameters0)

Share this post


Link to post
Share on other sites



$msi = @ScriptDir & "\ScreenConnect.ClientSetup.msi"
$name = $NamePart1 & " " & $Server & " " & $NamePart3
msgbox(0,'',$name)
$parameters0 = '/i "ScreenConnect.ClientSetup.msi" SERVICE_ARGUMENTS="?e=Access&y=Guest&h=screenconnect.sagesystem.com&p=8041&k=BgIAAACkAABSU0ExAAgAAAEAAQD%%2fVDhCLqj7LMgYl33xdWHbd%%2f7HE%%2b4auJrDTCCXpL7voDDmPHfn%%2ffOiqj5us%%2b1Nx8CMcVYAI00Taw4LuOere1udAB0UeJSxILJTL4HYYzdMy%%2fFsbNU9tPqfPfBp4YGShBIe5ejL7hnE7c31nrotgphuFyvx4vEvucjbLDUwhGreeXjOWAmNc7lCglingMY%%2fWjqOgjknVoM3O2jTjTkbfJXZgEHrinFfxdPcX4nmj5uP8dwG5kCg3bvVXjutP6OR5ESmfq56Bt%%2bj6M%%2bCULH8JeO7SjJF1baE5GMpewjuAJr6bM4WOVT7j0TSKKfsAvV4pgw33U3MwdMtO1YjLYfh%%2fUOx&t=%"'&$name&'"%&c=%"'&$CustomProperty1&'"%&c=&c=&c=&c=&c=&c=&c=" /qb'
;$parameters1 = '/i "ScreenConnect.ClientSetup.msi"'
ShellExecuteWait('msiexec', $parameters0)

 

Sorry, here's the code posted correctly.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now