MeghaHS

Controltreeview does not work

1 post in this topic

Hello,

         I am using Robotframework for desktop automation and I have imported AutoItLibrary to serve the purpose.I need to expand SysTreeView32 and click on an element but the treeview does not get expanded. I am using the below commands in RIDE editor:


Win Wait Active    11419302: ForexTimeFXTM-Standard-demo - Demo Account
${Handle}=    Control Get Handle    11419302: ForexTimeFXTM-Standard-demo - Demo Account    Navigator    [CLASS:SysTreeView32; INSTANCE:1]
Control Tree View    11419302: ForexTimeFXTM-Standard-demo - Demo Account    Navigator    ${Handle}    Expand    ForexTime (FXTM) MT4|Indicators    " "

Here is my AutoInfo tool details:

>>>> Window <<<<
Title:    Navigator
Class:    Afx:009F0000:8:00010003:00000000:00000000
Position:    287, 247
Size:    212, 235
Style:    0x94CC3100
ExStyle:    0x00000180
Handle:    0x00060736

>>>> Control <<<<
Class:    SysTreeView32
Instance:    1
ClassnameNN:    SysTreeView321
Name:    
Advanced (Class):    [CLASS:SysTreeView32; INSTANCE:1]
ID:    35439
Text:    
Position:    3, 5
Size:    191, 168
ControlClick Coords:    80, 87
Style:    0x50008003
ExStyle:    0x00000000
Handle:    0x000307B0

>>>> Mouse <<<<
Position:    378, 370
Cursor ID:    0
Color:    0xFFFFFF

>>>> StatusBar <<<<

>>>> ToolsBar <<<<

>>>> Visible Text <<<<
Navigator
Navigator


>>>> Hidden Text <<<<


Kindly help me to fix the Issue.

Thanks in Advance

 

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now