Sign in to follow this  
Followers 0
nitro322

CompileAU3.exe compiled file size?

5 posts in this topic

#1 ·  Posted (edited)

I'm using CompileAU3.exe to change the file properties on my compiled script (very cool, btw!). However, the compiled executable generated by CompileAU3.exe is significantly larger than the one I compile directly with AutoIt, using the following command:

Aut2Exe.exe /in UniExtract.au3 /out bin\UniExtract.exe /comp 4 /icon uniextract_exe.ico /nodecompile

As you can see, I use maximum compression, include a custom icon, and set the nodecompile option. This yeilds and .exe of 143 KB. When using CompileAU3.exe with similar options (the only difference being that I set a custom URL, version, and copyright), I get an .exe of 194 KB. Can anyone please explain why there's such a large difference? Is there anything I can do to reduce the file size?

Also, the compression setting seems to have no effect whatsoever. Minimum and Maximum both give me the exact same size. Why is this?

Thanks.

Edited by nitro322

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Your forgot to mention the size of your icon your using. The default AutoIt icon is very small in filesize to keep the compiled filesize down.

Edit: or are you using the same icon for comparison?

Edit: Compression is based on the files that are FileInstalled with the compiled script, not the upx compession used on the bin file.

Edited by MHz

Share this post


Link to post
Share on other sites

Your forgot to mention the size of your icon your using. The default AutoIt icon is very small in filesize to keep the compiled filesize down.

Edit: or are you using the same icon for comparison?

Edit: Compression is based on the files that are FileInstalled with the compiled script, not the upx compession used on the bin file.

Thanks for the reply, MHz. Yes, I'm using the same icon for comparison. The .ico file size is 24.6 KB. The CompileAU3.exe-generated binary is more than twice the size, which makes me think that it's not the icon that's causing the problem. Any other suggestions? Has anyone else ever (or not) noticed this?

Also, thanks for the info about the compression size. Definitely clears things up.

Share this post


Link to post
Share on other sites

I believe that in your case CompileAU3.exe is using the BETA version which makes it about 50Kb bigger.

Check for Compiler_directives in the source or Scriptfile.au3.ini file in the script directory and see if any of these point to the BETA version of AUt2EXE.


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Right you are! Somehow it picked up the beta .exe, even though I had the stable one toggled for default use. Works great now.

By the way, is it possible to change the Language? "Engligh (United Kingdom)" has always struck me as kind of odd, considering I've never even been there before.

Also, is it possible to compile a script "silently"? If I call it from the command line with the appropriate arguments, it sets the correct options, but then it sits there waiting for me to click Compile Script.

Thanks.

Edited by nitro322

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0