Jump to content
Sign in to follow this  
Zeusking

Compare an image with the screen

Recommended Posts

Zeusking

Hello guys, I wanted to know how I can compare one .png image with the screen, and when I find that image on the screen I get the X / Y.

Share this post


Link to post
Share on other sites
InunoTaishou

Look at this topic, download for it in the bottom of the post

 

Share this post


Link to post
Share on other sites
Zeusking
23 minutes ago, InunoTaishou said:

Look at this topic, download for it in the bottom of the post

 

Thanks, I downloaded it, but I think I'm doing something wrong because it never finds, have a way to do a loop instead of receive a error message?

Share this post


Link to post
Share on other sites
Zeusking

The error MSG:

>"C:\Program Files (x86)\AutoIt3\SciTE\..\autoit3.exe" /ErrorStdOut "C:\Users\AVELL\Documents\Bot\huntv01.au3"    
"C:\Users\AVELL\Documents\Bot\ImageSearch.au3" (44) : ==> Subscript used on non-accessible variable.:
if $result[0]="0" then return 0
if $result^ ERROR
>Exit code: 1    Time: 1.218
 

Share this post


Link to post
Share on other sites
JLogan3o13

@Zeusking what application are you trying to manipulate? Guarantee there is a better way to do it than ImageSearch


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites
Zeusking

So, I have a store and the trading system works with two computers, I need which the master computer automatically confirm.

Share this post


Link to post
Share on other sites
Zeusking

I need when this screen appears, click on 'SIM'

Share this post


Link to post
Share on other sites
Zeusking

5uO4IAJ.jpg

 

Just now, Zeusking said:

I need when this screen appears, click on 'SIM'

 

Share this post


Link to post
Share on other sites
Zeusking

Some one? im using now ImageSearch2015 and taking this error:

 

>"C:\Program Files (x86)\AutoIt3\SciTE\..\autoit3.exe" /ErrorStdOut "C:\Users\AVELL\Documents\Bot\adsa.au3"    
teste"C:\Users\AVELL\Documents\Bot\adsa.au3" (9) : ==> Unknown function name.:
$result = _ImageSearch($picture,1,$x1,y1,0,0)
$result = _ImageSearch($picture,1,$x1,^ ERROR
>Exit code: 1    Time: 0.3834

Share this post


Link to post
Share on other sites
JLogan3o13

@Zeusking please wait at least 24 hours before bumping your post. We understand that solving the issue is the most important thing in the world to you, but you need to show a little patience. We have volunteers on the forum all over the world; the person best suited to assist you may not be on right now.


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites
InunoTaishou

I'm a little concerned with why the path to your script is in a Bot folder

3 hours ago, Zeusking said:

Some one? im using now ImageSearch2015 and taking this error:

 

>"C:\Program Files (x86)\AutoIt3\SciTE\..\autoit3.exe" /ErrorStdOut "C:\Users\AVELL\Documents\Bot\adsa.au3"    
teste"C:\Users\AVELL\Documents\Bot\adsa.au3" (9) : ==> Unknown function name.:
$result = _ImageSearch($picture,1,$x1,y1,0,0)
$result = _ImageSearch($picture,1,$x1,^ ERROR
>Exit code: 1    Time: 0.3834

What application are you trying to automate?

Share this post


Link to post
Share on other sites
JLogan3o13

@InunoTaishou, asked and answered if you actually read the post. Lots of new users use the term bot without necessarily intending to break the forum rules; they are simply unaware that it throws red flags on this forum. Until something is actually presented that is against the rules, let's not harass the OP with the same questions.

Edited by JLogan3o13

√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites
InunoTaishou

Noted

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×