Sign in to follow this  
Followers 0
Hyflex

Running a command via command prompt in AutoIt

3 posts in this topic

Hi,

I'm trying to run the following command through command prompt but for some reason I can't get it to work with AutoIt.

start /realtime /b "" "C:\Program Files (x86)\VMware\VMware Workstation\VMWare.exe" -x "T:\VMs\RVM.vmx"


I've tried the following:

Run(@ComSpec & ' start /realtime /b "" "C:\Program Files (x86)\VMware\VMware Workstation\VMWare.exe" -x "T:\VMs\RVM.vmx"')


I've also tried a fair few other variations but all of them just do nothing, a few variations like the following just load a command prompt but nothing is entered or done...

Run(@ComSpec & ' start /b "" "C:\Program Files (x86)\VMware\VMware Workstation\VMWare.exe" -x "T:\VMs\RVM.vmx"')


Anyone have any suggestions to fix it so it runs?

Share this post


Link to post
Share on other sites



you can try something like this

RunWait(@ComSpec & " /c Start notepad.exe")

 

Share this post


Link to post
Share on other sites

Or: 

Run($sServer & $sParms, $sWorkingDir)

No need to run any DOS Command.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0