Armado

Finder Tool not working in some SAP screens

13 posts in this topic

#1 ·  Posted

Hi,

I am trying to fetch the right object i.e. SAP transaction code VA01 where you can enter the order type etc. While using the finder tool it is only fetching the whole screen, but not only the relevant part as order type where i want to enter my values by my script. Even while I am trying to do MouseClick by fetching the values from Finder Tool it is not working.

See screenshot it is not fetching the yellow marked position to enter the order type

Can somebody solve my issue?

Thanks and br

Armado

1.png

Share this post


Link to post
Share on other sites



#2 ·  Posted

I tried it like this:

 

winwait('SAP Easy Access')
WinActivate('SAP Easy Access')
MouseClick('primary',80,62,1,0)
Send('/NVA01')
Send('{ENTER}')
winwait(300)
WinActivate('Kundenauftrag anlegen: Einstieg')
MouseClick('primary',190,213,1,0) ----> This is not working!!!!! :(
Send('TA')
Send('{ENTER}')

Share this post


Link to post
Share on other sites

#4 ·  Posted

Hi junkew,

how to find and use them? Sorry I am totally new with Autoit.

Thanks

Armado

Share this post


Link to post
Share on other sites

#5 ·  Posted

Wrong tools, lookup SAP udf and SAPwizard

Share this post


Link to post
Share on other sites

#6 ·  Posted

Are there some examples which i can use for it? Thanks

Share this post


Link to post
Share on other sites

#7 ·  Posted

Can't find any examples here how to solve the issue. Thanks!

Share this post


Link to post
Share on other sites

#9 ·  Posted

Thanks junkew, will check the simple spy thing as this could be the right method ;). Thanks!

Share this post


Link to post
Share on other sites

#10 ·  Posted (edited)

Do you have the scriptable version of SAP? The pages with SAP UDF has Samples, SAPWizard will help define the target. With out access to the VA01 screen I can only point you in the right direction, Do you have any receiving/stores, as opposed to punching, screens you need access to? 

 

Edited by jitb

Share this post


Link to post
Share on other sites

#11 ·  Posted

Hi jitb,

no I do not have the scripting enabled in SAP. But I helped my self with using only once the mouse click and then only by tab or/and left or right and entering values. This works fine for now for me.

Thanks

Armado

Share this post


Link to post
Share on other sites

#12 ·  Posted

How sad (Scripting not enabled) But I'm glad you found a solution :-)

Share this post


Link to post
Share on other sites

#13 ·  Posted

thx ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now