nobbitry

#AutoIt3Wrapper-Problem with language codes?

5 posts in this topic

#1 ·  Posted

Hey guys,

I'm from germany and I want to use #AutoIt3Wrapper_Res_Language=1031 for german. But it doesn't work (even with other language codes). In the file properties I always see English Great Britain (respectively in german Englisch Großbritannien).

The codes I have from there: https://technet.microsoft.com/en-us/library/cc287874(v=office.12).aspx

Is there a problem, or am I misunderstanding the option?

 

(I'm using the SciTE Version 3.7.3 from February 26, 2017)

Share this post


Link to post
Share on other sites



#2 ·  Posted

This only sets the Resource language number so I am not sure what you are expecting it to do?
What exactly do you see in English you are expecting to be German?

Jos

 


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#3 ·  Posted

Hi Jos,

I thought/hoped it would set the language in the file properties. (I didn't find that in the #pragma compile options).

 

SciTE.jpgproperties.jpg

Share this post


Link to post
Share on other sites

#4 ·  Posted

Ah, it actually does but I bet you received this warning since you mix the #Pragma and #AutoIt3Wrapper_Res_* directives:

-    Ignoring all #AutoIt3Wrapper_* #directives that would normally update the VERSION section!

 They would both try to replace the VERSION section of the program resources so hence AutoIt3Wrapper is skipping it. So when you only use #AutoIt3_Res directives without any #PRAGMA, it will work as you expect.

Jos

 


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#5 ·  Posted

Jos, that's it!

I didn't see it before.. So either language or company? I think language is not so important. :D

Thank you very much.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now