Sign in to follow this  
Followers 0
Puckmeister

can`t solve this GUI-Problem...

7 posts in this topic

Hi all,

i hope someone can help me out with my problem.

I wrote this little app to manage my clipboard entries: :P Klip!

here is the compiled version and the source

my problem is when i use it often, it suddenly crashes with a strange behaviour. some windows won`t work anymore, i can open the startmenu but can`t klick shortcuts in it, alt-tab won`t work anymore and some other effects...

i think i exceed a technical limit in autoit, perhaps a buffer overflow.

when a new clipboard entry is found, the main gui is rebuild in the background, with the new content added.

before i build the new gui i delete the old one to prevent such an overflow. there seems to be an error. the gui has many controls, there are big contextmenus on the buttons, but the number don`t exceed the technical limit of 4096 GUI controls per window. suddenly when i reach a special amount of rebuilds the script crashes.

i added a splashscreen that shows the current number of the maingui-rebuilds, the number of controls in the current maingui and the number of all created controls ever and i recognized that the script crashes always when the counter of all created controls exceeds 10200 +-100.

also i added a small script which generates random code and puts it into the clipboard so that Klip! fills itself with data.

i think an internal cache is overflown at the time the script crashes, but i don`t find any informations about it. when a gui is deleted, will the generated controls from this gui still rest in some internal cache ? i checked all other technical limits described in the help and i think i doesn`t exceed one of them.

so if anyone has an idea please help me

greetz, chris

Share this post


Link to post
Share on other sites



just a guess:

maybe you should release the variables after or before guideleting- i'd suggest after

what do you mean with "release the variables" ?

greetz chris

Share this post


Link to post
Share on other sites

didn`t resolve the problem. i don`t know what i can test now, i think i checked all what i can. :P

Share this post


Link to post
Share on other sites

Nice program!

However your script is too long. Can you come up with a shorter version by removing extra features to ease checking.

My guess would be that DLL calls may be failing after repeated calls.

Share this post


Link to post
Share on other sites

hi,

thx for the replies, but it wasn`t dllcall, too.

i rewrote the code so that the main gui isn`t rebuilded everytime, but all controls are killed and the empty window is filled with new. now it works and i`ll upload the new version in the Klip!-Thread today.

there seems to be a bug when to often the same window with very many controls (mostly contextmenus) is build and deleted right afterwads.

i`ll post this n the bug section.

greetz, chris

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0