Sign in to follow this  
Followers 0
joseLB

aplication failed due configurations is incorrect

20 posts in this topic

Trying to run a compiled program, in some situations gives the message:

"This aplication has failed to start because the application configuration is incorrect."

The situation whe it gives the message:

- The file server where the .exe is located is a win 98 or win ME and the user PC is a Win XP, using explore and double cliking the .exe

- any other .exe tested (not a AutoiT compiled one) works fine

The same .exe runs OK if:

- the file server is a win XP or Linux file server with samba

- the Client (user PC) is win 98, no matter the file server it runs OK

Anyone have an idea of what is goin on? :P

Share this post


Link to post
Share on other sites



If you are for sure it is a bug just follow how to submit a "bug report" I mean give the script reproducing the error.

In your case I think you are more in the situation you need help so your post should have been post in the "support forum". I will move it into.

Coming back to your question it is very difficult to help you with out having access to to .exe

Share this post


Link to post
Share on other sites

check if you have read/write acces to your share on win98 and try connecting the share path to a mapped drive on the local system where your start script!

net use z: \\computer\e\dirapplication /USER:blabla

z:\scriptfile.exe

it maybe a PIPE probleme! because you don't have the probleme with winxp

try this too

net use \\computer\IPC$ /user:blabla

im not sure if this work for win98!

if it not working when you map the drive Z and you are sure about your right access! than i sugest you change your server for this file or RIP off win98 and put win2k (the best windows ever)

im sure the probleme come from autentification! in win98! maybe it the way autoit work too! but it not a bug! just another ... from microsoft!

you know the basic principle of Windows Platforme

Small Probleme = Reboot

Big Probleme = Reinstall

hehe this make me smile!

im joking about windows! but i love it! i think this is great job too! the mentaly around windows it not like linux but not everyone are perfect hehe :P


GreenseedMCSE+I, CCNA, A+Canada, QuebecMake Love Around You.

Share this post


Link to post
Share on other sites

Ok, Greenseed for yoru advice. But, as it hapens with ANY AU3 compiled .exe, and does NOT hapens with others .exe I tested, I think it could be a bug, or something like that. Why au3's .exe have this behavior?

Share this post


Link to post
Share on other sites

Does your program run or shell out to any other programs or utilities?

Check the program shortcut properties on both computers to make sure things like the working directory/folder and icons, etc are still valid.

Check if any of the environment variables are being used. Some settings will be different on each OS version.

Have you been playing around with any global system parameters such as DOS program settings to do with memory, etc?

Share this post


Link to post
Share on other sites

Cases where I'm seen behavior similar to this were scripts that used the Run function with no (or an incorrect) second argument (working directory).


Yes yes yes, there it was. Youth must go, ah yes. But youth is only being in a way like it might be an animal. No, it is not just being an animal so much as being like one of these malenky toys you viddy being sold in the streets, like little chellovecks made out of tin and with a spring inside and then a winding handle on the outside and you wind it up grrr grrr grrr and off it itties, like walking, O my brothers. But it itties in a straight line and bangs straight into things bang bang and it cannot help what it is doing. Being young is like being like one of these malenky machines.

Share this post


Link to post
Share on other sites

Dave

Thanks for your advice, inside the scripts I tested always there where run with no working directory specified. I will test it putting working dir. But, one thing intrigues me. I'm double cliking in the script .exe and not starting it thru another script, and receive imediatedly the message. The "run" inside the script would execute much later, after a GUI show and only if I select a specific option on it.

Share this post


Link to post
Share on other sites

Could AntiVirus software be causing problems? There have been problems in the past with AV programs flagging/deleting AutoIt exes...

In fact, both computers have antivirus, but, I don't think this is the problem, as none the AV flagged te .exe. ANd, when I'm in a win98 Client, it runs (AV=AVG lite)

Share this post


Link to post
Share on other sites

#10 ·  Posted (edited)

Does your program run or shell out to any other programs or utilities?

Check the program shortcut properties on both computers to make sure things like the working directory/folder and icons, etc are still valid.

Check if any of the environment variables are being used. Some settings will be different on each OS version.

Have you been playing around with any global system parameters such as DOS program settings to do with memory, etc?

All the shortcuts are OK, as from a Client win98 it works OK. But I didn't specified working dir in any run. I will do it this monday.

I'm calling external programs (run), done by myself in VB, blat.exe (for emails) and another autoit .exe.

I'm not using any environment variables (at least not declared or used any).

I'm not calling any DOS program.

But I'm running the autoit .exe directly with a double clik in explorer, after navigating the network. But remember, it works well when the client is w98 and always when the .exe is in a wXP.

Edited by joseLB

Share this post


Link to post
Share on other sites

All the shortcuts are OK, as from a Client win98 it works OK. But I didn't specified working dir in any run. I will do it this monday.

I'm calling external programs (run), done by myself in VB, blat.exe (for emails) and another autoit .exe.

I'm not using any environment variables (at least not declared or used any).

I'm not calling any DOS program.

But I'm running the autoit .exe directly with a double clik in explorer, after navigating the network. But remember, it works well when the client is w98 and always when the .exe is in a wXP.

Try adding the working dir as @scriptdir asuming the other exe's are in the same folder or @scriptdir\subfolder.

If there outside of the script folder you'll have to specify the full path

Share this post


Link to post
Share on other sites

I personally have seen this message due to AVG antivirus...

Lar.

Cris and Larry, thanks for your advice

This monday, at office, I will try 1) stoping AVG and 2) putting the working dir

I would like to tell some words about AutoIt.

First, I work/worked with prog. languages more yeas than I would like to tell (Jurassic?). Well, assembler in PDP11, IBM360, 370, 1130 and DOS and starting with the new PIC processors.

Fortran, basic, PL1, Algol, Cobol, gembase, Basic, a little VB, Pascal, Java & Javascript, and so on. Also I tried for a while macro Scheduler (not very sucessfull).

AutoIt surprises me.... besides it's stability (even with all that commands that interact with the OS) there is the beauty, correctness and ortogonality of the language. Not to mention things like StringInString, the ocurrance option with backwards search. I would like to thanks and congratulate the individuals that devise and made this jewel. I only can believe these guys are very clever and/or have lots of experience.

Could not let to mention all the attention I'm receiving at this forum.... great and thanks

Share this post


Link to post
Share on other sites

I did many tests, deactivating the antivirus, comenting any "run" command, and nothing worked.

So, I did this small script and even with it and antivirus deactivated, all problems continue, that is:

- the .exe is in a win98 PC

- in a PC with XP, in windows explorer, I go thru the network up to the folder where the .exe is

- double clik it, and receive the message.

- If I go locally to that win98 and in explorer double click it , it works fine

- If I seat in another win98, explorer thru network, double clik, it works OK

The test script:

;test program for "application configuration is incorrect"

Global $test1, $test2

$test1= "test was OK"

$test2= "this message will appear IF there is no problem in runing this program."&@cr& _

"The .exe must reside in a folder in win98 and the client is a XP" &@cr& _

"Just open the explorer in XP, go thru network to that folder and double click on the .exe"

MsgBox(4096,$test1, $test2 & @crlf & "end of this single message")

Share this post


Link to post
Share on other sites

About my last post. Nobody answered it. Would not be better to put it in bugs?

Share this post


Link to post
Share on other sites

I'm not really sure why that would affect anything XP would just see it as a folder. If you map a network drive as apposed to using just a path would this work?

Or try it with a local folder on XP and browse by the share locally to see if it is XP that has the issue

Have you tried it on different machines?

Share this post


Link to post
Share on other sites

I'm not really sure why that would affect anything XP would just see it as a folder. If you map a network drive as apposed to using just a path would this work?

Or try it with a local folder on XP and browse by the share locally to see if it is XP that has the issue

Have you tried it on different machines?

Thanks Cris

I tested and attached some printscreens as your suggestions. The problems persisted.

Yes, I tried in many XP and 98 milleniuns and combinations. ALways the same.

browsing locally it always will be ok, as if I'm in a XP the file will be in the XP and the same in 98. The problem only comes if from a Xp I go to a 98/millenium.

IF you have a small .exe of the more recent version of AU3 (I do not have the beta version) you can send me I could see if the problem persists or not. If not, good, the problem is solved...

Share this post


Link to post
Share on other sites

About my last post. Nobody answered it. Would not be better to put it in bugs?

I reproduce your behavior but for this it not related to AutoIt I did it executing a notepadXP.exe uploaded to a shared 98.

I have no idea why see you bug report

Share this post


Link to post
Share on other sites

This may be a stupid suggestion but....

Have you tried installing AutoIt on and compiling it on a win98 machine. Total long shot I know I just wondered if there were some permission thing going on when compiled.

*Prepares to get shot down in flames* :P

Share this post


Link to post
Share on other sites

This may be a stupid suggestion but....

Have you tried installing AutoIt on and compiling it on a win98 machine. Total long shot I know I just wondered if there were some permission thing going on when compiled.

*Prepares to get shot down in flames* :lmao:

I think it's a good guess. I will try it tomorrow, at office.

Share this post


Link to post
Share on other sites

I think it's a good guess. I will try it tomorrow, at office.

I am curious of the result as I don't see for now any reason why it should be different.

AutoIt is not supposed to reference special dll.

This running thru shared folder seems very special for Windows. :">

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0