LoWang

exe file icon missing

5 posts in this topic

#1 ·  Posted (edited)

Hello, I compile my script with an icon

#AutoIt3Wrapper_Icon=..\..\..\Users\VitezslavZurek\Pictures\ikony\shell32\shell32.dll_I0009_0409.ico

And then when I see it in Total Commander the icon is not visible! There is just this default rectangle for exe files. When I open explorer The icon is visible! When I open file properties the icon is also visible. I then copy file to our windows server and there the icon is not visible anywhere! Not in Total Commander nor in explorer. Weirdly enough when I look from another windows server (w2k8) via smb share on the first server (w2k12) I can see the file icon. WTH? Is the ICO file somehow incompatible with Windows 10 and W2K12 server?

shell32.dll_I0009_0409.ico

Edited by LoWang

Share this post


Link to post
Share on other sites



#3 ·  Posted

Hi @LoWang.

I've tried to duplicate your problem, but i have had no problems with the icon #AutoIt3Wrapper_Icon=shell32.dll_I0009_0409.ico

I tried on Windows 7 Ultimate Version 6.1 Build 7601, Windows 10 Home Version 1703 Build 15063.138

I also tried viewing the file with Total Commander, on the Windows 7 machine.

 

You may want to re-make the icon file via a graphic editor to see if something within the ICO file is corrupted and results in problems in specific cases.

Share this post


Link to post
Share on other sites

#4 ·  Posted

@genius257 have you tested the ICO file I attached to this post?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now