Sign in to follow this  
Followers 0
beiqi

Is there a bug in the AutoITX.dll

4 posts in this topic

Hello there!

I posted this message days ago, but i got no response, so I think maybe there is a wrong user group!

I want to use AutoIt to embeded into my application. In order to do that, I have used the AutoIt3.h given in the distribution. Most of the functions do their works correctly, but I can not use the function

AU3_RegDelete("keystring", "valuestring")

I have also got the link error if I use the example given under the sub-directory of AutoItX\StandardDLL\VC6\Example

only added in the WinMain function the following row:

AU3_RegDelete("HKEY_CURRENT_USER\Software\Somestring", "");

I got the error:

main error LNK2019: unresolved external symbol _AU3_RegDelete@8 referenced in function _WinMain@16

Thanks for your help in advance!

Boostpy

Share this post


Link to post
Share on other sites



Hi there,

ich have checked the AutoITX3.dll withDependency-Walker und found there does not exist ReDelete, which AutoIt3.h has AND instead of that, under the AutoIT there exist AU3_RegDeleteKey and AU3_RegDeleteVal, but they do not exist unter AutoIt3.h

I have tried AU3_RegDeleteKey with win32com under python to use them, IT WORKS!

Can someone give me the total description (Parameter list etc) or there is a new autoIt3.h, my version dated am 05 Feb. 2005

thanks in advance!

Boostpy

Share this post


Link to post
Share on other sites

Hi there!

I have changed my autoit3.h and added two functions:

AU3_RegDeleteKey(const char* strKey)

AU3_RegDeleteKey(const char* strKey, const char* strValueName)

it works with my application.

I would like to know:

1. is there a newer version autoit3.h that mine (005 Feb. 2005)

2. why should the author use two instead of one?

thanks for any advice or tips!

Boostpy

Share this post


Link to post
Share on other sites

Hi there!

I have changed my autoit3.h and added two functions:

AU3_RegDeleteKey(const char* strKey)

AU3_RegDeleteKey(const char* strKey, const char* strValueName)

it works with my application.

I would like to know:

1. is there a newer version autoit3.h that mine (005 Feb. 2005)

2. why should the author use two instead of one?

thanks for any advice or tips!

Boostpy

The 005 Feb. 2005 is the official release so there must be a bug if it is really working.

Beta is not covering this subject.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0