Sign in to follow this  
Followers 0
supraspecies

Expand RedgWrite

2 posts in this topic

#1 ·  Posted (edited)

Hi. I'm writing

RegWrite('HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers', @TempDir & '\Tunngle_Setup\Tunngle_Setup.exe', 'REG_SZ', 'WINXPSP3')

Problem is, in registry it gets written as

C:\Users\CHRIST~1\AppData\Local\Temp\Tunngle_Setup\Tunngle_Setup.exe

That is, my name isn't written fully. So since the path isn't full, compat flag doesn't apply. How do I force AutoIt to write full path? Thank you.

 

P.S. I am getting somewhere with

FileGetLongName

but it still writes short name to the registry. Reading I can figure out. Writing is the problem.

Edited by supraspecies

Share this post


Link to post
Share on other sites



#2 ·  Posted

The problem appears to be solved. I dug in the right direction:

$longname=FileGetLongName(@TempDir)

RegWrite('HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers', $longname & '\Tunngle_Setup\Tunngle_Setup.exe', 'REG_SZ', 'WINXPSP3')

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0