Tyranna

Input control sending massages to wrong function!

4 posts in this topic

#1 ·  Posted

I had an array of labels that displayed an array, and I decided I wanted to have the user be able to change the data.

So, I changed the labels to input controls.  Now when I change the information in the input control, and press enter, it runs my file save function...  wait what?

I cant seem to get it not to do this.  I am suspecting that the input control is sending some message informing the GUI that it had been modified, but I do not understand

why it would be producing messages that would activate one of my functions.  There is some control ID problem here I do not know about.

Share this post


Link to post
Share on other sites



#2 ·  Posted

It's probably in line 42, I'd look there.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

#3 ·  Posted

Probably because your button control that launches that function has this state assigned?

 

$BS_DEFPUSHBUTTON 0x0001 Creates a push button with a heavy black border. If the button is in a dialog box, the user can select the button by pressing the ENTER key, even when the button does not have the input focus. This style is useful for enabling the user to quickly select the most likely option, or default.

IEbyXPATH-Grab IE DOM objects by XPATH IEscriptRecord-Makings of an IE script recorder ExcelFromXML-Create Excel docs without excel installed GetAllWindowControls-Output all control data on a given window.

Share this post


Link to post
Share on other sites

#4 ·  Posted

I think you nailed it, I gad 129 for the style on all my bitmaped buttons, and when i set the one to 128 , the input activated a different button.

I set them all to 128 and I am seeing no effect other than expected.

 

Thanks, i thought I had those styles correct.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now