Jump to content
DanTran

Compiling Func Issue

Recommended Posts

DanTran

Hi, my Func ScanForSpur($SpurFreqStart, $SpurFreqStop) works fine alone, but being treated by AutoIT compiler as a For loop without terminated with a Next statement.  Can anyone help?  Attached are my codes.MT8212E - KratoNB - Spur.au3

Share this post


Link to post
Share on other sites
DanTran

"D:\IT\Autoit\AutoIt Macro\Anritsu Cell Master MT8212E\MT8212E - KratoNB - Spur.au3" (298) : ==> "For" statement has no matching "Next" statement.:
Func ScanForSpur($SpurFreqStart, $SpurFreqStop)

>Exit code: 1    Time: 0.4639

Share this post


Link to post
Share on other sites
JLogan3o13

Moved to the appropriate forum. No one seems able to read the notice on the DEV forum:

Quote

Do not create AutoIt-related topics here, use AutoIt General Help and Support

 


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites
ripdad

Quick glance...

Move Next at line 383 to line 295 ?

 

  • Like 1

"The mediocre teacher tells. The Good teacher explains. The superior teacher demonstrates. The great teacher inspires." -William Arthur Ward

Share this post


Link to post
Share on other sites
DanTran

Thank you ripdad.  It was my mistake.

I forgot that a function Func () can only be created once.  It cannot be in any repetitive loop.

My automation scrip is working flawlessly.

Dan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×