Sign in to follow this  
Followers 0
wnight77

Control ID

5 posts in this topic

ok so i wrote my own prog to grab some control ids from windows but heres the thing! my control send dosnt work!! check it out

ControlSend ( "Dark Age of Camelot, Copyright © 2001-05 Mythic Entertainment, Inc.", " ", "0x001B02E8", "1" )

is that the wrong form of the control id? aka hex? or is it soposed to be converted to something else for this function?? any ideas?

Share this post


Link to post
Share on other sites



ok so i wrote my own prog to grab some control ids from windows but heres the thing! my control send dosnt work!! check it out

ControlSend ( "Dark Age of Camelot, Copyright © 2001-05 Mythic Entertainment, Inc.", " ", "0x001B02E8", "1" )

is that the wrong form of the control id? aka hex? or is it soposed to be converted to something else for this function?? any ideas?

ususally it is like "Button1" as a controlid :P

try the hex without the quotes.


My UDF's:;mem stuff_Mem;ftp stuff_FTP ( OLD );inet stuff_INetGetSource ( OLD )_INetGetImage _INetBrowse ( Collection )_EncodeUrl_NetStat_Google;random stuff_iPixelSearch_DiceRoll

Share this post


Link to post
Share on other sites

heh i shoulda posted more i have it in like 5 forms trying to get it to work....

1 hex quotes

1 hez no quotes

1 dec quotes

1dec no quotes booo non worked

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Func get()

$i=ControlGetHandle ( "Dark Age of Camelot, Copyright © 2001-05 Mythic Entertainment, Inc.", "", "DAoCMWC1" )

MsgBox ( 1, "blah", $i )

EndFunc

this returns that value u are seeing

hmm wait so the control id is dAoCmwc1 and the HWND is that hex value?? but thats odd because this dosnt work ether

ControlSend ( "Dark Age of Camelot, Copyright © 2001-05 Mythic Entertainment, Inc.", " ", "DAoCMWC1", "1" )

quotes runs but dosnt work no quotes i cant even run it

hmm but that cant be right ether becauase...

Control ID:

ClassNameNN: DAoCMWC1

Edited by wnight77

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

no its working as intended the way i have it....

now i gota find a way to make autoit tell what window is what... i have 2 windows with the exact same name and ID why cant i use the HWND!! darn it! or can i.... =-=)

if anyone knows feal free to enlighten me

Edited by wnight77

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0