Jump to content

_FTP_ProgressUpload uploads 0 byte length files


Recommended Posts

Hi,

Using _FTP_ProgressUpload to upload a number of files to the server.
The script is based closely on example1 script from the help file and all seem to work and no errors are returned.
But the files end up being 0 bytes in length.
I believe same script worked with Autoit v. 3.0.100

What could be wrong here ?

Cheers
/Poul


Func UploaderFil()
    Local $fuFunctionToCall = _UpdateProgress
    ProgressOn("Uploader....", $s_RemoteFile)
    $iResultat = _FTP_ProgressUpload($Conn, $s_LocalFile, $s_RemoteFile, $fuFunctionToCall)
    ProgressOff()
    $tCur = _Date_Time_GetSystemTime()
    If $iResultat = 0 Then
        $i_Fejl += 1
        MsgBox(48, "Fejl", "Fejl ved FTP-upload !", 5)
        IniWrite($Inifilen, "Setup", "SidsteStatus - " & $FilNum, "FEJL - FTP upload - den : " & _Date_Time_SystemTimeToDateTimeStr($tCur, 1))
    Else
        IniWrite($Inifilen, "Setup", "SidsteStatus - " & $FilNum, "OK - FTP upload - den : " & _Date_Time_SystemTimeToDateTimeStr($tCur, 1))
    EndIf
EndFunc   ;==>UploaderFil

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By rootx
      $FTPOpen = _FTP_Open($FTPName) ConsoleWrite("Status + "&$FTPOpen&@CRLF) ConsoleWrite("Wait Connection to " & $FTPServer & "..."&@LF) $FTPConnect = _FTP_Connect($FTPOpen, $FTPServer, $User, $Pass, $iPassive, $iPort) ConsoleWrite($FTPOpen & " + " & $FTPServer & " + " & $User & " + " & $Pass & @LF) $FTPUpload = _FTP_DirPutContents($FTPConnect, $InstallFolder, $FTPlocation, 1, 0) ConsoleWrite($FTPConnect & " + From " & $InstallFolder & " + To " & $FTPlocation & @LF) Example() _FTP_Close($FTPOpen) I would like to add a progress bar in my FTP upload.
      Sorry, I had read the help but I could not make it work, could someone help me please?
×
×
  • Create New...