Jump to content
Sign in to follow this  
VSiAQ

A question about IniRead

Recommended Posts

VSiAQ

I've just finish one ultility. It first check the script's folder for an INI file (e.g, vsiaq.ini). If it doesn't exist, the ultility will exit. Otherwise, it will read the ini file, add the values into a combo box. It works perfectly on my computer, running Windows XP SP1.

I passed it to one of my friends, but it didn't work. Seem that my ultility find the INI (it show the gui instead of exiting), but can't read the ini file's content. I mean, nothing is added into the combo box. The Ini file isn't damaged, though. He's running Windows 2000 SP4 Russian Version.

Why does it happen? Can anyone give me advices?

Thanks a lot.

Share this post


Link to post
Share on other sites
LxP

Are you reading the INI file like this? --

INIRead(@ScriptDir & '\VSiAQ.ini', ...)

Note the use of @ScriptDir which ensures that the file is found during the INIRead().

Share this post


Link to post
Share on other sites
VSiAQ

I asked him about his problem.

I think it's problem with AutoIt itself, as he said that using my app in WinXP is okay. However, when he switch to Win2000 SP4, it can't function correctly.

Share this post


Link to post
Share on other sites
MHz

nobby has a good request. Anything could be the problem here and without anything to see then anything could be dreamed up to be the solution. Only speaking as I have no Russian OS experience but anything shared can help to point to the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.