Jump to content
Sign in to follow this  
Retep

_FileListToArray problems under Windows 10

Recommended Posts

My AutoIt (v3.3.14.5) script uses _FileListToArray and was working fine under Windows 10. However, with the latest update for Windows 10 (OS Build 17134) my script stops working with _FileListToArray returning "." instead of file or folder names.

Is there any known issue with Windows 10 and _FileListToArray?

Share this post


Link to post
Share on other sites

Agreed, I am working on some scripts for a client now on Windows 10 that rely heavily on _FileListToArray and have notice no issues on the latest version of Windows 10. If you are encountering a specific issue, please post a reproducer so we can assist.


"Profanity is the last vestige of the feeble mind. For the man who cannot express himself forcibly through intellect must do so through shock and awe" - Spencer W. Kimball

How to get your question answered on this forum!

Share this post


Link to post
Share on other sites

I finally found the reason for my problem: When a file name begins with one of the characters "$" or "'" and this file is on a remote computer _FileListToArray just returns "." instead of file names.

$FileList = _FileListToArray("\\My-PC\D\Music\Archive\")

When the folder "Archive" contains a file "$Alan Parsons Project - Tales of Mystery and Imagination.m3u" then _FileListToArray won't work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...