Jump to content
MRAJ

Run autoit scripts on windows servers

Recommended Posts

MRAJ
Posted (edited)

Hi,

I have created around 50 GUI autoit scripts for different applications and these scripts i want to run in different windows 2012 servers or same server all time one by one. How to achieve this.

 

Edited by MRAJ

Share this post


Link to post
Share on other sites
MRAJ

Do i have to run in Task scheduler.. Please suggest.

Share this post


Link to post
Share on other sites
JLogan3o13

@MRAJ first off, as you have been asked before, please wait 24 hours before bumping your threads - this may be the most important thing in the world to you, but it doesn't mean everyone is going to leap to your assistance. Please show some patience.

Secondly, as you have also been asked before, please add some actual details to your threads. What are the GUI scripts doing? Are you expecting them to run while the server is locked/not logged in/etc.? Are they supposed to run in a specific order? Help us help you.


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites
MRAJ

Yes..i want them to run even after server is locked/not logged in/etc...

GUI scripts doing?

Ans- These scripts are like logging to URL, giving username and password,clicking on text,link,button,navigating,submit the values etc.

Share this post


Link to post
Share on other sites
BrewManNH
3 minutes ago, MRAJ said:

These scripts are like logging to URL, giving username and password

On a server? Why are you doing this on a server? Servers aren't supposed to be used to surf the web.

  • Like 2

If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
orbs

there are valid reasons to use servers as desktops - bearing in mind that "servers" simply refers to the type of the OS, rather than to the actual usage of the computer running that OS. one such reason (which i encountered personally) is that major cloud service providers (such as Amazon AWS and Microsoft Azure) offer servers as the preferred option, sometimes not offering desktops at all. and since Windows servers are, after all, Windows, they support full desktop capabilities. either way, when working with servers or with dedicated (probably headless) desktops, one encounters the same caveats.

@MRAJ, are you actively trying to make us focus on the least important bits of your case? you have provided no indication that you ever tried to run your scripts, to say nothing of the issues you encountered or any troubleshooting efforts. so, what is your problem?

 

 

  • Like 1

Share this post


Link to post
Share on other sites
MRAJ

In task scheduler i schedule one of my script which runs every 5 mins..but the script is not running if i logged off or locked. 

Share this post


Link to post
Share on other sites
Juvigy

GUI scripts need to have a user logged on for them to work! If it is locked , it should work.

Share this post


Link to post
Share on other sites
MRAJ

I am seeing Last run time and run result as success and completed in Task schedule but the script running is hidden and not able to see GUI of the web application script, how it is running or to find if it is stuck or it is running as expected.

Share this post


Link to post
Share on other sites
Juvigy

That means that the script has run and has finished. Check out your code.

Share this post


Link to post
Share on other sites
aa2zz6

In your script does it leave the while loop at anytime? Like @Juvigy said, it sounds like it's running and finishing. Do you have a log file associated with your script so you can tracks each step so you can identify the issue?

Share this post


Link to post
Share on other sites
MRAJ

I didnt used while loop..only i used If & Else statement . Below is the result in task schedule but i am not able to see the GUI of the running scriptimage.png.8f63fed6de2a6a1eb49fe3782e8cfe04.png

And after sometime it shows the below result in task scheduler:

image.png.2611cac85407b9518a8e68ded2b22aff.png

Share this post


Link to post
Share on other sites
JLogan3o13
7 minutes ago, MRAJ said:

but i am not able to see the GUI of the running script

Did you set up the scheduled task to run interactively (run only when user is logged in)? Otherwise, it is going to run in the isolated session 0 and you aren't going to see anything, that is by design.


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites
Juvigy

The second msg means that you or the TS have tried to start a second instance of the same script. There are settings on the TS that specify how the TS should handle this.

Share this post


Link to post
Share on other sites
MRAJ

Thanks.i have scheduled 2 scripts and configured both Run when user is logged on. I am seeing one is running in GUI mode but another script is running but not in GUI mode.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×