Sign in to follow this  
Followers 0
Meszaros Csaba

Solution for multiple GUIs

16 posts in this topic

Hi everybody!

I found a good solution for my problem with multiple GUIs. You've probably noticed that if you create a new GUI and after its removal trying to acces the old one it just doesn't work.

Solution (no codes, just a simple idea):

1. Create your main window ($main)

2. Add buttons, etc.

3. Assign a function (for ex. SecondWindow()) to a button...

4. In the SecondWindow() function create a new GUI as a $main' s child. (Add $main as a parent GUI parameter). Name it $subwindow.

5. Use the GUIGetMsg() construction.

6. On a second window's created button add :

GUIDelete($subwindow)

Return

You will find it very easy to handle.

I have written a parametric GUI designer program, in wich you can create GUIs, add controls. It's for home use, but I hope you'll enjoy it!

And don't forget: JESUS LOVES YOU!!!

Share this post


Link to post
Share on other sites



Cant someone kick this ASSHOLE off before he fills the site with this crap.



Get Beta versions Here Get latest SciTE editor Here AutoIt 1-2-3 by Valuater - A great starting point.

Time you enjoyed wasting is not wasted time ......T.S. Elliot
Suspense is worse than disappointment................Robert Burns
God help the man who won't help himself, because no-one else will...........My Grandmother

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

I'm giving him the benefit of the doubt for the moment -- he may not realise that he is actually creating new threads (if you click the Back and Forward buttons the forum listings won't refresh).

He appears to be having trouble uploading his attachment from what I can see. All of the attachments are corrupt.

Edit: I've sent him a PM. If the threads continue to spawn then we have a spammer.

Edited by LxP

Share this post


Link to post
Share on other sites

nup, someone removed the attachments he made.


[size=20]My File Upload[/size]Register at my site and upload.

Share this post


Link to post
Share on other sites

Yes -- most likely him because they were corrupt.

Share this post


Link to post
Share on other sites

I'm giving him the benefit of the doubt for the moment -- he may not realise that he is actually creating new threads (if you click the Back and Forward buttons the forum listings won't refresh).

He appears to be having trouble uploading his attachment from what I can see.

Reading what he writes I get the impression he is in the wrong forum. I think he should be posting in Scripts and Scraps. Maybe he is still full of the Christmas spirit.


Get Beta versions Here Get latest SciTE editor Here AutoIt 1-2-3 by Valuater - A great starting point.

Time you enjoyed wasting is not wasted time ......T.S. Elliot
Suspense is worse than disappointment................Robert Burns
God help the man who won't help himself, because no-one else will...........My Grandmother

Share this post


Link to post
Share on other sites

lol, its amazing how you reply so fast, its just like chatting :P


[size=20]My File Upload[/size]Register at my site and upload.

Share this post


Link to post
Share on other sites

lol, its amazing how you reply so fast, its just like chatting :P

I am just a sad git with nothing else to do. :lmao:


Get Beta versions Here Get latest SciTE editor Here AutoIt 1-2-3 by Valuater - A great starting point.

Time you enjoyed wasting is not wasted time ......T.S. Elliot
Suspense is worse than disappointment................Robert Burns
God help the man who won't help himself, because no-one else will...........My Grandmother

Share this post


Link to post
Share on other sites

#9 ·  Posted (edited)

I can confirm that the original poster is just having a hard time attaching their file to the post:

···

I have so called "broadband" wireless internet, but when I'm trying to upload my stuff, simply nothing happens.

···

This explains what is happening -- the user was therefore not realising that so many threads were being created. Edited by LxP

Share this post


Link to post
Share on other sites

I can confirm that the original poster is just having a hard time attaching their file to the post:

I apologise for calling him an ASSHOLE, it must be my hangover that is making me short tempered.


Get Beta versions Here Get latest SciTE editor Here AutoIt 1-2-3 by Valuater - A great starting point.

Time you enjoyed wasting is not wasted time ......T.S. Elliot
Suspense is worse than disappointment................Robert Burns
God help the man who won't help himself, because no-one else will...........My Grandmother

Share this post


Link to post
Share on other sites

A Scott with a hangover, now there's a concept :P!


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

A Scott with a hangover, now there's a concept :lmao:!

It happens when we drink wine instead of whisky. :P


Get Beta versions Here Get latest SciTE editor Here AutoIt 1-2-3 by Valuater - A great starting point.

Time you enjoyed wasting is not wasted time ......T.S. Elliot
Suspense is worse than disappointment................Robert Burns
God help the man who won't help himself, because no-one else will...........My Grandmother

Share this post


Link to post
Share on other sites

Csaba,

It appears that the file that you are trying to attach is quite large (at least 900KB). You may wish to try uploading it to http://www.autoitscript.com/fileman/ instead and then provide a link.

Share this post


Link to post
Share on other sites

Csaba,

if you are not for sure how to upload ask first.

Thanks :P

Share this post


Link to post
Share on other sites

The file is available here:

http://www.autoitscript.com/fileman/users/public/Csaba/gui_it_3.zip (1.27 MB)

The archive consists of a couple compiled scripts however they are decompilable without a password. Clearly a lot of effort has gone into this too so it's worth a look.

Share this post


Link to post
Share on other sites

The file is available here:

http://www.autoitscript.com/fileman/users/public/Csaba/gui_it_3.zip (1.27 MB)

The archive consists of a couple compiled scripts however they are decompilable without a password. Clearly a lot of effort has gone into this too so it's worth a look.

Thanks LxP for helping Csaba :lmao:

Welcome Csaba in the AutoIt world :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0