Jump to content
Sign in to follow this  
DjDeep00

ActiveX Control in Tabitem

Recommended Posts

Hi, i am unable to view an activex control in a tab item.

Ex.

$Tab=GUICtrlCreateTab (10,50, 480,350)

$Tab0=GUICtrlCreateTabitem ("Test")

$oIE = ObjCreate("Shell.Explorer.2")

$GUIActiveX = GUICtrlCreateObj($oIE, 220, 100, 250, 280)

$oIE.navigate("C:\Documents and Settings\testl\Desktop\Order.xml")

The activex control appears behind the tab. Please advise.

Thanks in advance..

Edited by DjDeep00

Share this post


Link to post
Share on other sites

I don't think that is possible to manage a Obj control embedded on a tab. the Obj control do what he want.

So perhaps some Obj can be embedded and work on tab but not this one. :P

kjactive certainly can confirm what can be done.

Share this post


Link to post
Share on other sites

I don't think that is possible to manage a Obj control embedded on a tab. the Obj control do what he want.

So perhaps some Obj can be embedded and work on tab but not this one. :lmao:

kjactive certainly can confirm what can be done.

Sorry, a very late reaction to this topic. With AutoIt beta versions 3.1.1.100 (and older), you have to add an additional line to make the control visible:

GUICtrlSetStyle($oIE, $WS_VISIBLE)

I have submitted a modification to GUICtrlCreateObj(), so it will set WS_VISIBLE by default (next beta version).

Regards,

-Sven

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...