Sign in to follow this  
Followers 0
DamnYouAll

Ie In The Backround

12 posts in this topic

i am trying to run ie in the backround and fill some forms on pages i knwo i have to use control but how should i use it with minimize or hide and what control command to send TAB and letters? thanks

Share this post


Link to post
Share on other sites



This should get you started:

AutoItSetOption("WinTitleMatchMode",2)
$IEPATH= "c:\program files\internet explorer\iexplore.exe" & " www.google.com"
Run($IEPATH,"",@SW_MINIMIZE)
Sleep(3000)
;ControlSend("Microsoft Internet Explorer","","Edit1","www.google.com" & "{ENTER}")
ControlSend("Google - Microsoft Internet Explorer","","Internet Explorer_Server1","AutoIt3" & "{ENTER}")
Sleep(2000)
WinSetState("Google", "",@SW_MAXIMIZE)

Share this post


Link to post
Share on other sites

i got it to work but i cant use it to send an @symbol ive tried to use + and {SHIFT} but i always get a 2 not an @ . alnd when i try to use 2 controlsends in thr same script the second one doesn''t work?

Share this post


Link to post
Share on other sites

no i am using it in a control send so can i put a send command inside a control send

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

I guess what i wanted to ask is: What did you use in the controlsend command, because you talk about + and {SHIFT} where i think the @ can be used just as is...

Controlsend("title...","text...","Control....", "text@site.com")

Edited by JdeB

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

just like that with the @ but it would just put a 2

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

can you post an example code that gives you this issue when you run it, so we can have a look en test it ?

Edited by JdeB

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#9 ·  Posted (edited)

sleep(1000)

controlsend('name',"",'Internet Explorer_Server1','

andromedarising blank@wit.edu')

always put a 2 for @weird

Edited by DamnYouAll

Share this post


Link to post
Share on other sites

just tried it out and worked fine for me..... :D

controlsend('Google - Microsoft Internet Explorer',"",'Internet Explorer_Server1','andromedarising blank@wit.edu',)

What OS&anguage are you running ??


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

windows xp pro and english the one u had worked but i figured out to to do it with out using it now. thanks for all your help

Share this post


Link to post
Share on other sites

#12 ·  Posted (edited)

well i got it to send when it is open but when i minimize it it doesn't do anything. is there any way in a control send to send tabs cuz i am using {TAB 12} should this work?

also wiht controlclick can u put in xy cordanites to click at a pos while it is minimized?

Edited by DamnYouAll

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0