Sign in to follow this  
Followers 0
TWC

RC.exe Error

11 posts in this topic

I am getiing the following error when I compile a script.

"RC.Exe (3) : Error : Resources information will not be updated in target program!"

This only occurs with on this one script.

I am Running:(3.1.1.99)

Can I get some guidance on troubleshooting this?

Any suggestion appreciated.

Share this post


Link to post
Share on other sites



Make sure you have RC.exe : Program Files\AutoIt3\SciTe\CompileAU3


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

No I don't, and I can't find it on my system with search.

Can you point me to this file?

THANX

Share this post


Link to post
Share on other sites

Hmm, where I posted it was exactly where mine is. I assume you did a system search?... did you try to redownload beta / SciTe / and 3.1.1?


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

Yes, I tried a reinstall.

I have found that RC.exe is installed during the compile process and deleted after use by CompileAu3.au3.

I can compile other scripts and all work as expected.

There must be an error being created within my script. I don't know what may cause this error so I am sort of dead in the water.

Any thoughts that can shed some light on this will be appreciated.

THANX

Share this post


Link to post
Share on other sites

Yes, I tried a reinstall.

I have found that RC.exe is installed during the compile process and deleted after use by CompileAu3.au3.

I can compile other scripts and all work as expected.

There must be an error being created within my script. I don't know what may cause this error so I am sort of dead in the water.

Any thoughts that can shed some light on this will be appreciated.

THANX

Could you post some of your script so that people can look to see if the problem is with your script as the problem only happens with one.


Get Beta versions Here Get latest SciTE editor Here AutoIt 1-2-3 by Valuater - A great starting point.

Time you enjoyed wasting is not wasted time ......T.S. Elliot
Suspense is worse than disappointment................Robert Burns
God help the man who won't help himself, because no-one else will...........My Grandmother

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

This is the culprit script that generates the RC.exe error. I would appreciate it if someone could compile it and try to regenerate the error. I would also appreciate any feedback.

THANX

Edit: Script was fine, the error was at the keyboard.

Edited by TWC

Share this post


Link to post
Share on other sites

I am getiing the following error when I compile a script.

"RC.Exe (3) : Error : Resources information will not be updated in target program!"

This only occurs with on this one script.

I am Running:(3.1.1.99)

Can I get some guidance on troubleshooting this?

Any suggestion appreciated.

This error can be received if you have the Update Target program resources information checked and no information is provided, in which can cause error. The error is most possibly by no information or incorrect information for the resources. Your script looks ok for compiling.

Note: RC.exe is FileInstalled to @TempDir if it is not found in the ComplieAu3 directory.

Share this post


Link to post
Share on other sites

.

Note: RC.exe is FileInstalled to @TempDir if it is not found in the ComplieAu3 directory.

Hey, I didn't know that... Nice one MHz!


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

Just for future reference, RC.EXE is "Microsoft Resource Compiler". I found a copy of RC.EXE under

"C:\Program Files\AutoIt3\SciTe\CompileAU3"

whose properties say it's version 5.0.2051.1, but if you run rc /? says it's version 5.1.2264.1 (go figure!).

I found it referenced at MSDN as part of the download at:

Download details Windows® Server 2003 SP1 Platform SDK Web Install

If you download and install

PSDK-x86.exe,

it will be installed under "C:\Program Files\Microsoft Platform SDK\Bin".

This one reports version 5.1.3609.0 in the file's properties, but version 5.2.3690.0 if you run RC /?.

It looks like the syntax is the same for both versions and should work for the SciTe editor/compiler.

The package installs a TON of stuff - downloaded during the installation - but there's some other interesting stuff there - most of which is over my head, but might be useful to others here.

Share this post


Link to post
Share on other sites

This error can be received if you have the Update Target program resources information checked and no information is provided, in which can cause error. The error is most possibly by no information or incorrect information for the resources. Your script looks ok for compiling.

Note: RC.exe is FileInstalled to @TempDir if it is not found in the ComplieAu3 directory.

THANX, That was it.

I had updated resource information except for version that I left blank. This caused the error I reported. Thank you to all and sorry for the trouble due to operator error.

TWC

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0