Jump to content
Sign in to follow this  
Dazed

Windows Auth Box Issue

Recommended Posts

This is an odd one I need some help with. We have a selenium c# automation project with a windows auth box. We were passing in the user/pass in the url string but we started to notice some issues. I wanted to setup AutoIT (used it before on many projects and always works great!) and see if this fixed the issue we were seeing but the url we go to is an internal ip:port. Should not matter but when I goto the url ex. 12.34.56.78:1111 the browser (chrome and ie) opens and pops the modal but then fails with:

OpenQA.Selenium.WebDriverException: 'The HTTP request to the remote WebDriver server for URL http://localhost:7233/session/be85ee0483da9772b136488bed19c43b/url timed out after 180 seconds.'

It appears that webdriver is waiting for something to complete and I can't get to the next step.  I then tried Firefox which actually adds the user/pass and logs in but fails from this point forward because it thinks there is a modal open when there is not. I tried to close the mythical modal but then it threw an error that no modal exists. 

I have tried the below but each one loads the page and then throws the error.
    
    _webDriver.Navigate().GoToUrl(url);
    _webDriver.Url = url;

I am thinking this is an issue with selenium or possibly some internal security setting we may be using. I wanted to see if anyone else is seeing this issue or ran into it before and has a work around. Any ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...