Jump to content
Sign in to follow this  
Bitnugger

Scintilla failed with status 1. SciTE will now close.

Recommended Posts

I have just noticed that the first script in the appendix crashes SciTE4AutoIt3 if I use a version (SciTE.exe/SciLexer.dll) that is greater than 3.7.5.0.

If the script is opened in a new SciTE instance, it will happen immediately when loading, if it is added to an already opened SciTE instance, it will not happen until, for example, try to execute the file with F5.

The error source I could already narrow down a bit, it's up to the last comment block, if I remove this, everything is easy.

WMPlayer_OCX_Radio (Crash!).au3 WMPlayer_OCX_Radio (OK!).au3

Share this post


Link to post
Share on other sites

Just tried with SciTE v 4.1.2 (latest Beta) and it opens the file without any issues  when double clicking the file and no SciTE started yet.

Jos


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

 

14 hours ago, Jos said:

Are you mixing Scilexer.dll & SciTE.exe?

Yes, I had the current SciLexer.dll 4.1.2.0 and SciTE.exe 3.7.5.0, because there were problems with Lua (Procedure entry point luaL_register not found) with the current version of SciTE. But then I also tested it with the current SciTE version 4.1.2.0, so that the error occured as well. Now I'm using SciTE and SciLexer with version 3.7.5.0 for the time being, as long as that was not fixed with Lua. Then I will like to test it again.

Share this post


Link to post
Share on other sites
9 hours ago, Bitnugger said:

Procedure entry point luaL_register not found

You really shouldn't mix versions too much as that could give problems. Which version of Windows are you running as I am not familiar with that error?
Have you tried the latest BETA version of SciTE & SciLExer as well?

Jos


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
10 hours ago, Jos said:

You really shouldn't mix versions too much as that could give problems.

I do not. I installed the current version of SciTE4AutoIt3 (Date updated 2-1-2019). Because this version causes problems with Lua, I have replaced the SciTE.exe (4.1.2.0) with SciTE.exe (3.7.5.0) and except for the script shown here, I had no problems with this combination. Due to the error with the script I have now also replaced the SciLexer.dll (4.1.2.0) with SciLexer.dll (3.7.5.0).

10 hours ago, Jos said:

Which version of Windows are you running as I am not familiar with that error?

Microsoft Windows [Version 10.0.17763.557]
AutoIt 3.3.14.5 AU3Check 3.3.15.1 AutoIt3Wrapper v.18.708.1148.9 SciTE v.3.7.5.0   Keyboard:00000407  OS:WIN_10/  CPU:X64 OS:X64  Environment(Language:0407)  CodePage:65001  utf8.auto.check:4

10 hours ago, Jos said:

Have you tried the latest BETA version of SciTE & SciLExer as well?

Yes I have. With that I can load the script without error message, but as soon as I start an action (for example F5) or end SciTE, I get this error message again. With all other 4.x versions the message appears directly when opening the script.

Edited by Bitnugger

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...