Jump to content

#AutoIt3Wrapper_UseX64=Y not working when running script outside SciTE - SQLite3_x64


Recommended Posts

I have a script that runs on start up.

Recently I added SQLite SQLite.au3 - using sqlite3_x64.dll. Hence I added #AutoIt3Wrapper_UseX64=Y.

The script runs without issues from SciTE, but can't get it to run on start up / manually. _SQLite_Startup throws an error.

Now, when I right click the file and manually run it as x64, no issues.

Link to post
Share on other sites
  • Developers

How do you run the script at startup?  Compiled or  with the AutoIT exe?
When the latter: What is the commandline you run at startup?
Care the share what the error is that is thrown or do you like us to guess? ;) 

Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites
4 minutes ago, Jos said:

How do you run the script at startup?  Compiled or  with the AutoIT exe?

I have a shortcut to the *.au3 file in my start up folder.

4 minutes ago, Jos said:

When the latter: What is the commandline you run at startup?

Not sure what you're asking since I only made a shortcut.

4 minutes ago, Jos said:

Care the share what the error is that is thrown or do you like us to guess?

_SQLite_Startup throws error 1. But since it works without issues when run manually as x64, I assumed the error number is irrelevant since the reason for the error seems obvious - despite the #AutoIt3Wrapper_UseX64=Y in the au3 file, when the file is doubleclicked it runs (seems to at least) as x86.

Thanks

Link to post
Share on other sites
  • Developers
49 minutes ago, Seminko said:

I have a shortcut to the *.au3 file in my start up folder.

Let me guess: The .au3 file extension defaults to AutoIt3.exe in stead of the required AutoIt3_x64.exe?

49 minutes ago, Seminko said:

Not sure what you're asking since I only made a shortcut.

A Shortcut does contain a commandline, which in this case should point to the proper AutoIt3 version executable.

Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...