Jump to content
iAmNewbe

No Color For Custom Compiler Directive

Recommended Posts

Posted (edited)

I created a new compiler directive.  It works though the color in the au3 file is not changing in Scite.  I have looked in every file having to do with this and I can not find where the coloring occurs.  How can I associate this new directive to the same color as the rest of the directives?

The new directive temporarily removes some console writes from the normal output to minimize scrolling and adds spacing lines for easy reading of output my scripts create.  

The color is not being matched though, I am not sure where this occurs.  I just want the color to match the built-in directives. 

Anyone that can share how to do this? 

 

I am using the full AutoIT version of Scite 4.12 with AutoIT 3.3.14.5

 

slice1.png

Edited by iAmNewbe

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, iAmNewbe said:

I have looked in every file having to do with this and I can not find where the coloring occurs. 

Guess you didn't look in : autoit3wrapper.keywords.properties ;) 

...  but this means you can't upgrade SciTE4Autoit3 without either loosing or merging all your changes.

Jos

Edited by Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...