Jump to content
Stacker

need help - scite editor bug

Recommended Posts

Hi i have a big issue with scite.

in win7 stop working. when i open scite or a file au3 text is not visible (grey or black backgrounds) if i copy all and paste on notepad i have full text.

i think is d2d dll .  if i download from scintilla (non autoit version)  i have no problem but i can't compile with it.

 

AUTOIT.jpg

Share this post


Link to post
Share on other sites
Posted (edited)

Musashi-C64.png

"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."

Share this post


Link to post
Share on other sites
Posted (edited)
59 minutes ago, Musashi said:

i have reinstalled all package. (tryed uninstall/install)  same problem

 

in safe mode run...

i uninstall amd video driver and now work..

 

Edited by Stacker

Share this post


Link to post
Share on other sites
Posted (edited)

You probably did make some modification in SciTEUser.properties. 

  • Go into SciTE.
  • Select Options/Open User Options File.
  • Check for the color settings. ( or simply save the contents somewhere and empty the file to reset everything)

Alternatively ensure you have he Full SciTE4AutoIt3 installed. Open SciTEConfig and load the default theme to reset the changes in SciTEConfig.properties.

Edit: Just saw your update:

29 minutes ago, Stacker said:

i uninstall amd video driver and now work..

 

Check the helpfile for  "technology" and play with the different options available.             

Jos

Edited by Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
1 hour ago, Jos said:

You probably did make some modification in SciTEUser.properties. 

  • Go into SciTE.
  • Select Options/Open User Options File.
  • Check for the color settings. ( or simply save the contents somewhere and empty the file to reset everything)

Alternatively ensure you have he Full SciTE4AutoIt3 installed. Open SciTEConfig and load the default theme to reset the changes in SciTEConfig.properties.

Edit: Just saw your update:

 

Check the helpfile for  "technology" and play with the different options available.             

Jos

i can't find this "Check the helpfile for  "technology" and play with the different options available.       "

Share this post


Link to post
Share on other sites

Open the SciTE4AutoIt3 helpfile (Ctrl+f1) and search for "technology" would be a good start. ;) 
That should get a hit for the SciTE page and then search he page that should give you:

technology On Windows Vista or newer, this can be set to 1, 2 or 3 to use the Direct2D and DirectWrite APIs for higher quality antialiased drawing or 0 to use the older GDI. The default is 1. The value 2 causes the frame to be retained after presentation which may prevent drawing failures on some cards and drivers. 3 may also prevent drawing failures on some cards and drivers but with lower speed.

Jos


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...