Jump to content

Recommended Posts

Hi,

I've been a very long time lurker, but finally need to post something.

I built a small client-server to be used in many projects building from Autoit-Socket-IO-4.0.0-beta. Locally it works fine. I uploaded the server to my dedicated server and used an existing port I've had open for many years and the client refused to connect. I used the example chat provided with the UDF system and still won't connect. I then tried various things and running an none autoit server.exe on the same port worked. I then grabbed a random Client-Server example from here and it connected instantly.

Is there some flag/value I'm missing? It feels like the Autoit-Socket isn't binding, although when I run the same server twice, it says "failed to listen is it already listening" so I would assume I'm wrong. I changed port to 7997 (my already open port I've used for years) on both Client and Server and changed @IPAddress1 in the Client to my servers external IP "104.xxx.xxx.x98" everything else is default. Same Port/IP works with the random C&S Example I linked above.

Just the default Autoit-Socket (found here) chat example failed and the send data/ping pong examples don't work. Anyone have any ideas? I'd prefer to use this very nice UDF base as I already expanded on it (GUI Wise) and it has everything I need.

Doug

 

 

Link to post
Share on other sites

I couldn't find any rules on bumping so I left it 12 hours, but wanted to give a little update (could not edit my OP):

I used the Autoit-Socket Server and I was able to connect to it with the posted Client example which showed "15:30:09 -- a|0x737C30783631373537343638353236353731373536353733373424496E7433327C30#" in the little window. So I can narrow it down to the Client being unable to connect to the Server at this point.

I'm currently trying to figure it out by mishmashing the two projects, the UDF seems to use the same TCPConnect so I'm stumped at the issue.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...