Jump to content

General Error: Error launching web driver! - (Moved)


Recommended Posts

Hello,

 

I'm running the demo script ( wd_demo.au3) I select edge and any option from the menu and it fails to launch the edge browser 

Below is what I get from the script , the log file is not created 

__WD_IsLatestRelease: True
_WD_IsLatestRelease ==> Success
_WD_Startup: OS:    WIN_10 WIN32_NT 18363 
_WD_Startup: AutoIt:    3.3.14.5
_WD_Startup: WD.au3:    0.4.1.0 (Up to date)
_WD_Startup: WinHTTP:    1.6.4.2
_WD_Startup: Driver:    msedgedriver.exe
_WD_Startup: Params:    --verbose --log-path="C:\Autoit\edge\WebDriver-0.4.1.0\msedge.log"
_WD_Startup: Port:    9515
_WD_Startup ==> General Error: Error launching web driver!

 

When i run the Msedgedriver manual I get a dos box with the below 

Starting MSEdgeDriver 92.0.902.84 (c04f45e8f08ccf4fb4388efae578d6565cf7a982) on port 9515
Only local connections are allowed.
Please see https://chromedriver.chromium.org/security-considerations for suggestions on keeping MSEdgeDriver safe.
MSEdgeDriver was started successfully.

 

Any ideas what I'm doing wrong ?

 

 

 

Link to post
Share on other sites

Ok thanks that resolved that issue , now have a new one 

When running the script to test navigation , dos box opens with this 

Starting MSEdgeDriver 92.0.902.84 (c04f45e8f08ccf4fb4388efae578d6565cf7a982) on port 9515
Only local connections are allowed.
Please see https://chromedriver.chromium.org/security-considerations for suggestions on keeping MSEdgeDriver safe.
MSEdgeDriver was started successfully.
[5336:256:0827/145353.516:ERROR:storage_reserve.cc(164)] Failed to open file to mark as storage reserve: C:\Users\paul\AppData\Local\Temp\scoped_dir17736_80341943\Default\Code Cache\js

DevTools listening on ws://127.0.0.1:56662/devtools/browser/477da222-323f-4813-8117-195f079c1f2d
[5336:12724:0827/145353.723:ERROR:edge_auth_errors.cc(385)] EDGE_IDENTITY: Get Default OS Account failed: Error: Primary Error: kImplicitSignInFailure, Secondary Error: kAccountProviderFetchError, Platform error: 0, Error string:
 

And the Edge browser opens and has an url of data:,

 

Link to post
Share on other sites
  • Developers

Moved to the appropriate forum, as the AutoIt Example Scripts forum very clearly states:

Quote

Share your cool AutoIt scripts, UDFs and applications with others.


Do not post general support questions here, instead use the AutoIt Help and Support forums.

Moderation Team

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites

Below is what is posted 

 

 

_WD_IsLatestRelease: True
_WD_IsLatestRelease ==> Success
_WD_Startup: OS:    WIN_10 WIN32_NT 18363 
_WD_Startup: AutoIt:    3.3.14.5
_WD_Startup: WD.au3:    0.4.1.0 (Up to date)
_WD_Startup: WinHTTP:    1.6.4.2
_WD_Startup: Driver:    C:\LBD1277\Autoit\edge\msedgedriver.exe
_WD_Startup: Params:    --verbose --log-path="C:\LBD1277\Autoit\edge\WebDriver-0.4.1.0\msedge.log"
_WD_Startup: Port:    9515
__WD_Post: URL=HTTP://127.0.0.1:9515/session; $sData={"capabilities": {"alwaysMatch": {"ms:edgeOptions": {"binary": "C:/Program Files (x86)/Microsoft/Edge/Application/msedge.exe", "excludeSwitches": [ "enable-automation"], "useAutomationExtension": false}}}}
__WD_Post: StatusCode=0; ResponseText=WinHTTP request timed out before Webdriver...
__WD_Post ==> Send / Recv error: WinHTTP request timed out before Webdriver
_WD_CreateSession: WinHTTP request timed out before Webdriver
_WD_CreateSession ==> Webdriver Exception: HTTP status = 0

Link to post
Share on other sites

Not sure that it will make a difference, but you could try this modified $sDesiredCapabilities definition --

$sDesiredCapabilities = '{"capabilities": {"alwaysMatch": {"ms:edgeOptions": {"excludeSwitches": [ "enable-automation"], "useAutomationExtension": false}}}}'

You could also check msedge.log to see if it's contents could help diagnose the issue.

Link to post
Share on other sites

 

Hello,

 

Below is what I have already , looks like it matches your except for the Binary details

$sDesiredCapabilities = '{"capabilities": {"alwaysMatch": {"ms:edgeOptions": {"binary": "' & "C:/Program Files (x86)" & '/Microsoft/Edge/Application/msedge.exe", "excludeSwitches": [ "enable-automation"], "useAutomationExtension": false}}}}'

I attached the log file, I'm not seeing anything that stands out as an issue

 

msedge.log

Link to post
Share on other sites
54 minutes ago, HighlanderSword said:

Below is what I have already , looks like it matches your except for the Binary details

Exactly. I wanted you to try without the "binary" portion. It probably won't change anything, but it's worth a shot.

Edit: Your log file appears to be missing a ton of details. I can only guess that there is something wrong with your MSEdge setup.

Edit #2: It appears that your browser version (92.0.902.73) is out of sync with your webdriver version (92.0.902.84). I would recommend addressing that and then report back your findings.

Edited by Danp2
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...