Sign in to follow this  
Followers 0
flaxcrack

TCP Help

2 posts in this topic

I have two scripts. One server and the other client. If I start the server first and then the client I should get a message box that say ding. Any help would be great!

;server.au3
$g_IP = "127.0.0.1"

TCPStartUp()

$MainSocket = TCPListen($g_IP, 65432,  100 )
If $MainSocket = -1 Then Exit

While 1
$ConnectedSocket = TCPAccept( $MainSocket)
$DataRec = TCPRecv($MainSocket, 512)

If $ConnectedSocket >= 0 Then 
    msgbox(0,"","my server - Client Connected")
    MsgBox(0,"Test", $DataRec)
EndIf

Wend

;client.au3
TCPStartUp()
$socket = TCPConnect( "127.0.0.1", 65432 )
TCPSend($socket, "Ding")
If $socket = -1 Then Exit

[quote] Gilbertson's Law: Nothing is foolproof to a sufficiently talented fool.Sandro Alvares: Flaxcrack is please not noob! i can report you is stop stupid. The Post[/quote]I made this: FWD & MD5PWD()

Share this post


Link to post
Share on other sites



I fixed it! Never mind... :lmao:

$DataRec = TCPRecv($ConnectedSocket, 512)

[quote] Gilbertson's Law: Nothing is foolproof to a sufficiently talented fool.Sandro Alvares: Flaxcrack is please not noob! i can report you is stop stupid. The Post[/quote]I made this: FWD & MD5PWD()

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0