Jump to content

AutoIt ObjCreate Throws Error After Upgrading .net 4.7.2 to .net 4.8


Recommended Posts

I have been using AutoIt V3.3.14.5 calling a C# custom DLL to find the control names on WPF forms in a Windows 10 app that was targeted to .net 4.7.2.

This has worked flawlessly for many years.  We just rebuilt our Windows 10 app with Visual Studio 2019 and .net 4.8.  The attached sample code now errors out (80040154) with the ObjCreate call.

I have tried the .net 4.8 patch, signing the DLL, AutoIt V3.3.14.5 beta version and many other things without success.

When I uninstall .net 4.8 (KB448129) and reinstall .net 4.7.2 everything works again.

This is on Windows 10 Build 1607.

The Windows 10 app also has WinForms and they work with both .net versions.

It is only the WPF forms and .net 4.8 that don't work.

Are there any other things I can try?SimpleWPF.au3

Link to post
Share on other sites

also if you want the dll to work, set up a dev vm, and install your product, then put source for the product and dll on the dev test vm. 

 

then you can debug your stuff in the debugger. this is the best way to get your dll fixed. debug it on a target with the source code. you probably don't need the app source but I would so you can walk through everything and see what exception is being thrown in the DLL method

also add logging to the DLL so you can easily debug using a log file. i do this with everything. makes it lots easier

Edited by Earthshine

My resources are limited. You must ask the right questions

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...