Jump to content

Recommended Posts

  • Developers

Those options are in the Full separate installer version of SciTE4AutoIt3. So what are you missing and what are you currently running ?

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites
  • Developers
2 hours ago, ashraful089 said:

maybe line by line debug like Visual studio or MikroC will make this tool more efficient and user friendly for novice or mid level programmer.

This is a feature that would need to be implemented in AutoIt3 first to allow for that, which isn't the case now.

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites
  • Developers

That is because you are in a comment block at that time and then the autocomplete is disabled. I always use #ce (short and sweet) :) 

Edited by Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites
  • Developers

These are the styles the AutoComplete is disabled for:

Quote

        SCE_AU3_COMMENTBLOCK,
        SCE_AU3_COMMENT,
        SCE_AU3_STRING,
        SCE_AU3_SPECIAL,
        SCE_AU3_COMOBJ

 

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites
  • Developers

@ashraful089,

I had a look at this one and have made a some changes in AutoItAutoComplete.lua and SmartAutoCompleteHide.lua :

  • Show AutoComplete when #c is typed in a commentblock.
  • Disable AutoComplete in a #Directive line after a space or = sign

Just replace those 2 in the SciTE Lua to implement the change.

Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...