Jump to content

Cannot use AutoIt in my own directory - (Moved)


Recommended Posts

Hello,

I use AutoIt in order to drive simulators for testing. I developped, several years ago, a set of scripts that I used successfully. In order to be independant from the machine on which my tests were running I moved the AutoIt directory into my testing directory (which also contains my testing tool's project). It was running fine. Last year, though, it did not work anymore. When I was launching the scripts, the simulator windows were no longer recognized, I couldn't find out why.

Now that I have some time to fix this, I decided to get the latest version. Installation was done in my Program files directory. I changed the paths and when I ran a script, it worked. When I moved the AutoIt3 directory into my own directory and reset to the former paths, however, it failed and shown the same error message.

Any idea of why it works several years and suddenly failed ?

Link to post
Share on other sites
  • Developers
54 minutes ago, Krogold said:

Any idea of why it works several years and suddenly failed ?

Right ...   I am sure you made a mistake somewhere but you really should understand that the provided information is FAR from complete. There is actually no info what so ever for us to go on. ;) 

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites
  • 2 weeks later...

Pls. run your code from within SciTE editor and post the results in the 

Propably you make use of #include statements. Change all of these to absolute paths.

#include <my-udf.au3>
#include 'C:\users\MyProfile\MyProject\My-UDF.au3'

 

 

Earth is flat, pigs can fly, and Nuclear Power is SAFE!

Link to post
Share on other sites
  • 2 weeks later...

Download ZIP version of AutoIt and Scite4AutoIt3 and extract them to desired folders instead of installing/moving from installers.

https://www.autoitscript.com/cgi-bin/getfile.pl?autoit3/autoit-v3.zip

https://www.autoitscript.com/cgi-bin/getfile.pl?../autoit3/scite/download/SciTE4AutoIt3_Portable.zip

You may also use #AutoIt3Dir directive like this:

#AutoIt3Wrapper_AutoIt3Dir=c:\path\to\autoit3\3.3.8.1

 

See here

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...