Jump to content

ScITE editor for Windows 2000


Go to solution Solved by Sailor77,

Recommended Posts

The editor in the last AutoIt package for W2k (v3.3.8.1) isn't recognized as a valid EXE by W2K. (Apparently it needed to be compiled by an earlier version of Visual Studio in order to work on W2K.)  Is there a version that will work, or does anyone have an alternative they could recommend? I don't have VS myself.

Thanks

Link to post
Share on other sites
  • Developers

Have you tried the Older SciTE version for WIn95 still available on https://www.autoitscript.com/site/autoit-script-editor/downloads/ ?

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites
11 hours ago, Danp2 said:

Ditch W2K. Problem solved. 😏

True, but I'm a beggar for punishment. I'm making my old systems talk and share seamlessly and reliably. I've chucked out all my hardware earlier than NT, the idea of making WWG311 cooperate seemed a bit pointless. Although I've still got the installation disks, and ditto for DOS. But I really loved W2K, so ....

 

11 hours ago, Jos said:

Have you tried the Older SciTE version for WIn95

No, I haven't, yet. Without knowing the development path of SciTE, I figured the very early versions may be a bit lacking (compared to more recent). What I have thought of is to progressively d/l earlier AutoIT packages than 3.3.8.1 until I find a version of the editor that runs on W2K. Who knows, maybe I will finish up with that W95 one after all.🙂

 

Thanks for your input, guys...

Link to post
Share on other sites
  • Solution

Ok, in v3.3.8.1 on the W2K system I replaced the SciTE folder with the corresponding folder from v3.3.6.1. The editor runs, I can create a file and invoke it, so it looks like I'm good to go. Fingers crossed.

Link to post
Share on other sites
  • Developers
5 hours ago, Sailor77 said:

I figured the very early versions may be a bit lacking (compared to more recent).

True, but support tends to be dropped for old unsupported OSes, so yes not everything will work as it will in the new releases, but there really is no option here. Soon the next SciTE v5 will also be available in the SciTE4AutoIt3 version at which time we totally drop the WinXP support. Such is life. ;) 

Jos 

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...