Jump to content

c# Application with Autoit crashes on launch with no message.


Go to solution Solved by undcover,

Recommended Posts

  • Solution
Posted (edited)

Damn, it works fine on my virtual Win11 (even though I don't have the correct CPU for it...) Seems to be a problem in that exact PC which means I'm gonna have to spend lots of time understanding why it's crashing... Didn't even have to install Autoit or any other regedit trick for it to work.

 

Quote

 

My application keeps crashing on startup on  Windows 11,the same application runs great across three different win10 pcs.
I remember having the same error before but installing Autoit on the target machine and/or adding the DLLSurrogate in the RegEdit usually made it work.
Not this time it crashes no matter how many things I changed.

Changed Click Once , changed Target CPU, changed how I imported the DLL, changed how I distribute the application, copied the whole release folder. nothing worked.

once i removed autoit references, it works immediately.

Any help would be great.

 

currently creating VM to try debugging on my own pc

Edited by undcover
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...