Sign in to follow this  
Followers 0
Daz

Logging Onto A Dlink DWL-2000AP

7 posts in this topic

Hi

I'm want to be able to automatically configure one of the above Wireless Access point using it's web interface. I can get it's log-in screen to come up but the page fetche's up a smaller log-in window which I'm at at loss at how to pass the username and password to. If anyone can help me I'd be grateful.

Regards

Daz

Share this post


Link to post
Share on other sites



It may be easier to setup telnet and configure it that way. Check this link for more info.

Share this post


Link to post
Share on other sites

It may be easier to setup telnet and configure it that way. Check this link for more info.

Hi

Thanks for the response. Unfortunetly the DWL 2000AP+ doesn't support Telnet (As far as I can tell anyway, there are no options to turn it on or off and the device doesn't respond when I try to telnet to it)

Share this post


Link to post
Share on other sites

Hi

Thanks for the response. Unfortunetly the DWL 2000AP+ doesn't support Telnet (As far as I can tell anyway, there are no options to turn it on or off and the device doesn't respond when I try to telnet to it)

Did you even look at the link I provided? I looked at DLinks support page again and all models have the same setting in the same place.

This comes straight from the link:

Step 1 Open your web browser such as Internet Explorer and enter the IP address of the DWL-2100AP in the Address bar and press Enter. The default IP address is 192.168.0.50.

Step 2 Enter your username (admin) and your password (leave blank by default). Click OK.

Step 3 Select the Tools tab and then click Misc. on the left side.

Posted Image

Step 4 To enable Telnet, check the Enabled check box next to Status. Select the timeout from the drop-down list.

Step 5 Click Apply then Continue to save the settings.

Advanced users can use Telnet to configure this unit. Go to Start > Run and type in telnet 192.168.0.50 and press enter. Enter the username (admin) and your password (just press enter by default). Telnet commands are not supported by D-Link Tech Support. Use at your own risk.

To prevent users from using Telnet, next to Status, uncheck the Enabled box (see above).

Share this post


Link to post
Share on other sites

Hi

I'm want to be able to automatically configure one of the above Wireless Access point using it's web interface. I can get it's log-in screen to come up but the page fetche's up a smaller log-in window which I'm at at loss at how to pass the username and password to. If anyone can help me I'd be grateful.

Regards

Daz

Hi Daz,

a couple of days ago I had a similar problem with my Siemens WLAN/DSL SE515 router.

I created the following script, it logs into the router and changes the mac-list.

Since your router is different you will have to modify the code but it might be a start.

Regards

Istra711

here my code:

-----------------------------------------

; This file will add or delete a user from/to the routers mac list by using the web-interface

; target router is a Siemens SE515 DSL WLAN Router

; You need to include the "IE.au3" libray !!!

; Please keep in mind, this file contains mac addresses and passwords of your system !!!!

; network - security might be in danger !!!

#include <IE.au3>

Dim $mac_array[7]

;name of the user that should be modified

$user = "admin"

;ip-address of the router

$ip_router = "192.168.1.1"

;routers password:

$router_pw = "default"

Select

case $user = "admin"

$person_name = "HansImGlueck"

;MAC-Address of the users wlan

$person_mac = "00:00:00:00:00"

EndSelect

;split mac address

$mac_array = StringSplit ($person_mac,":")

;check if router is on the network

$PingSE515 = Ping($ip_router,3000)

; When the function fails (returns 0) @error contains extended information:

; 1 = Host is offline

; 2 = Host is unreachable

; 3 = Bad destination

; 4 = Other errors

Select

Case @error = 1

$error = "Host is offline"

Case @error = 2

$error = "Host is unreachable"

Case @error = 3

$error = "Bad destination"

Case @error = 4

$error = "Other errors"

Case Else

$error = "N.A."

EndSelect

If $PingSE515 Then

; Msgbox(0,"Status","Online, roundtrip was:" & $PingSE515)

Else

Msgbox(0,"Status","Router is not online!" & @CRLF & "Please check the setup!" & @CRLF & @CRLF & "Possible errors: " & $error)

exit

EndIf

;Log into the router's web-interface.....

$o_IE = _IECreate()

_IENavigate($o_IE, $ip_router)

;wait for updated page

_IELoadWait($o_IE,50)

;get pointers to the login form and password field

$o_form = _IEFormGetObjByName($o_IE, "login")

$o_password = _IEFormElementGetObjByName($o_form, "password")

;Set field values and submit the form

_IEFormElementSetValue($o_password, $router_pw)

$oSubmitButton = _IEFormElementGetObjByName($o_Form, "Submit")

$oSubmitButton.Click

;wait for updated page

_IELoadWait($o_IE,50)

;the "url" of the mac-address-list of the router

_IENavigate($o_IE, "http://192.168.1.1/wlctrl.htm")

;wait for updated page

_IELoadWait($o_IE,50)

; get reference to Html-Form of the MAC-list

$oForm = _IEFormGetObjByName($o_IE, "tF0")

;parse html-content of page for start of MAC-list

$body = _IEBodyReadHTML($o_IE)

$StringPosition = StringInStr($body, "Geräte-Name")

If $StringPosition Then

; MsgBox(0, "Success", "The ""Geräte-Name"" was found")

Else

; MsgBox(0, "Fail", "The ""Geräte-Name"" was NOT found")

EndIf

$len = StringLen($body)

;MsgBox(0, "String length is:", $len)

;separate list from rest of the string

$bodyright = StringRight($body, ($len-$StringPosition))

;MsgBox(0, "Rightmost characters are:", $bodyright)

If StringInStr($bodyright,$person_mac) Then

MsgBox(0, $user, $user & " has internet access!")

$InternetAccess = 1

Else

MsgBox(0, $user, $user & " has no internet access!")

$InternetAccess = 0

endif

If ($InternetAccess = True) Then

$UserSelection = MsgBox(4, $user, "Should " & $user & "'s internet access be deactivated?")

If $UserSelection = 7 then

_IEQuit($o_IE)

exit

endif

; deactivate internet access of user

$len = StringLen($bodyright)

$StringPosition = StringInStr($bodyright,"""doDelete('" & $person_mac & "')"" type=button value=Löschen name=Submit3>")

$bodyleft = StringLeft($bodyright, ($StringPosition))

; find the Index of the "Submit3"-Button of the MAC-address that should be deleted

$SubmitButton_Index = 0

While StringInStr($bodyleft, "Submit3")

$len = StringLen($bodyleft)

$StringPosition = StringInStr($bodyleft, "Submit3")

$bodyleft = StringRight($bodyleft, ($len-$StringPosition))

$SubmitButton_Index = $SubmitButton_Index + 1

wend

$oSubmitButton = _IEFormElementGetObjByName($oForm, "Submit3", $SubmitButton_Index)

$oSubmitButton.Click

Else

; Should user be activated ?

$UserSelection = MsgBox(4, $user, "Should " & $user & "'s internet access be activated?")

If $UserSelection = 7 then

_IEQuit($o_IE)

exit

endif

; fill form with MAC-address values

Dim $oField[7]

For $index = 1 to 6

$StringMAC = "wlMac" & $index & "D"

$oField[$index] = _IEFormElementGetObjByName($oForm, $StringMAC)

_IEFormElementSetValue($oField[$index], $mac_array[$index])

Next

$oFieldHostName = _IEFormElementGetObjByName($oForm, "hostNameD")

_IEFormElementSetValue($oFieldHostName, $person_name)

Sleep(1000); wait a couple of milli seconds

; add MAC-address

$oSubmitButton1 = _IEFormElementGetObjByName($oForm, "Submit1")

$oSubmitButton1.Click

MsgBox(0, $user, $user & "internet access was activated!")

endif

;wait for updated page

_IELoadWait($o_IE,50)

; submit new settings "Click Anwenden"

$oForm = _IEFormGetObjByName($o_IE, "tF0")

$oSubmitButton1 = _IEFormElementGetObjByName($oForm, "Submit2")

$oSubmitButton1.Click

Sleep(1000)

_IEQuit($o_IE)

Exit

---------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

Did you even look at the link I provided? I looked at DLinks support page again and all models have the same setting in the same place.

This comes straight from the link:

Hi

I did look at your link and I think there was a mistake on my part, the model I have is the DWL 2000AP+, In my earlier message I missed off the '+' by mistake. WHen I looked the model up, following your link, a screen came up saying that my model isn't distributed in the U.S. and therefore not supported by the U.S. Dlink support website. It then gives me a choice of going to various international sites. Going to the UK site (which is where I live) I've looked for anything about Telnet in reference to my kit and I can't. I've included couple of pictures to show you what options I have through the web menus and I have gone into each screen looking for options similar to the ones you showed in your picture and have not found anything even close.

Regards

Daz

Share this post


Link to post
Share on other sites

You might see if there is a fireware update for it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0