Jump to content

Image search not working when calling from another Script


Recommended Posts

StarTech_1920.au3Carnival_1920.au3

When i am running Startech_1920.au3, Carnival_1920.au3, NetFlix_1920.au3 it detects the image/ images and working fully. but when i am Calling  Startech_1920.exe, Carnival_1920.exe, NetFlix_1920.exe through Task_Manager.au3 they dont detect image. i tired several times but not getting any idea what the problem is really.
Note: I am unable to post the whole work due to attachment size shortage.

If anyone know kindly help

Thanks in advance

NetFlix.png

Carnival.PNG

StarTech.PNG

Task_Manager.au3 NetFlix_1920.au3

Link to post
Share on other sites
  • Developers

Likely a WorkDir issue as your file references are relative! so make sure you do a FileChangeDir(@ScriptDir) at the start of your script.

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites

@Josmaybe not. i am noob in programming :(
Sorry if i am out of track. pardon me

What i did in the script. i am searching the image from a folder. Like Carnival_1920.PNG is under a folder of Carnival_1920. Which is being searched by Carnival_1920.exe
If i am running carnival.exe image search working, but if i am running carnival.exe by AppManager.au3 carnival.exe not detecting image. i am unable to post the pic of directory

Local $Carnival = _ImageSearch('Carnival_Image_1920\Carnival.png', 1, $Carnival_X, $Carnival_Y, 100)

Link to post
Share on other sites
  • Developers
Posted (edited)

I told you what I think you need to do in my initial response! 

2 hours ago, Jos said:

so make sure you do a FileChangeDir(@ScriptDir) at the start of your script.

So you really need to try and understand what is said. ;) 

Edited by Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites

Sir, did you mean to add " FileChangeDir(@ScriptDir) " for every scripts start to change its current directory to script directory?

Though i was using 'Carnival_Image_1920\Carnival.png' its the detailed path of the image. 


now my question is: when i am running the Task_Manager script is my directory set to Task_Manager.au3 folder?

By the way, Many Many Thanks. its detecting image now

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...