Sign in to follow this  
Followers 0
ScriptingSteve

Unable to Locate DLL running AutoIt script on Windows 2000

5 posts in this topic

I have an AutoIt script compiled with 3.1.1.92 that runs in my company's logon script.

Most computers are Windows XP, but a few are Windows 2000. On only a few Windows 2000 computers, the user receives this error:

"AutoIt V3: {executable name} - Unable to Locate DLL

The dynamic link library RASFIL32.DLL could not be found inthe specified path...."

and the script halts.

It's the first time I've had a script error like this. Can anyone explain the dependency?

Thanks,

Share this post


Link to post
Share on other sites



I have an AutoIt script compiled with 3.1.1.92 that runs in my company's logon script.

Most computers are Windows XP, but a few are Windows 2000. On only a few Windows 2000 computers, the user receives this error:

"AutoIt V3: {executable name} - Unable to Locate DLL

The dynamic link library RASFIL32.DLL could not be found inthe specified path...."

and the script halts.

It's the first time I've had a script error like this. Can anyone explain the dependency?

Thanks,

I doubt that Autoit3 is giving this error....

Are you running any programs with this login script that does something with RAS settings?


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

I have an AutoIt script compiled with 3.1.1.92 that runs in my company's logon script.

Most computers are Windows XP, but a few are Windows 2000. On only a few Windows 2000 computers, the user receives this error:

"AutoIt V3: {executable name} - Unable to Locate DLL

The dynamic link library RASFIL32.DLL could not be found inthe specified path...."

and the script halts.

It's the first time I've had a script error like this. Can anyone explain the dependency?

Thanks,

I'm on Windows XP SP2 and I don't have RASFIL32.DLL either. I also went here: http://www.processlibrary.com/dll/ and there was no such file posted. I did a search on google.com and the things that I found was in regards to Remote Access. What does your script do?


[quote] Gilbertson's Law: Nothing is foolproof to a sufficiently talented fool.Sandro Alvares: Flaxcrack is please not noob! i can report you is stop stupid. The Post[/quote]I made this: FWD & MD5PWD()

Share this post


Link to post
Share on other sites

I'm on Windows XP SP2 and I don't have RASFIL32.DLL either. I also went here: http://www.processlibrary.com/dll/ and there was no such file posted. I did a search on google.com and the things that I found was in regards to Remote Access. What does your script do?

The script checks for user eligibility by looking up user and computer goup membership in Active Directory using an ADO connection. If the user or computer is not found in specified groups, the script executes anoterh script using the Runas command.

There is nothing in my code dealing with RAS.

Share this post


Link to post
Share on other sites

I doubt that Autoit3 is giving this error....

Are you running any programs with this login script that does something with RAS settings?

My program is launched by the logon script. The logon script is a Kix32 script that does check RAS settings.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0