Sign in to follow this  
Followers 0
mbevan

aut2exe (beta release) error when generating file

5 posts in this topic

I have been using beta versions off autoit for some time now to make use of GUI forms - using v3.1.1.111 currently on a PC running Windows XP SP2.

Sinve I started using the beta versions a few months ago I have found when compiling an autoit script (any script) if a custom icon is selected for generated exe aut2exe crashes :

"Aut2Exe.exe has encountered a problem and needs to close. We are sorry for the inconvenience.

Error Signature

AppName: aut2exe.exe AppVer: 3.0.102.0 ModName: aut2exe.exe

ModVer: 3.0.102.0 Offset: 0000332e"

I can compile the same script and use default icons fine.

The compilation works fine - default or specified icon if I replace the aut2exe.exe file from the beta release with the one from the current release version of autoit3 - and the generated exe seems to work ok when executed

Share this post


Link to post
Share on other sites



I have been using beta versions off autoit for some time now to make use of GUI forms - using v3.1.1.111 currently on a PC running Windows XP SP2.

Sinve I started using the beta versions a few months ago I have found when compiling an autoit script (any script) if a custom icon is selected for generated exe aut2exe crashes :

"Aut2Exe.exe has encountered a problem and needs to close. We are sorry for the inconvenience.

Error Signature

AppName: aut2exe.exe AppVer: 3.0.102.0 ModName: aut2exe.exe

ModVer: 3.0.102.0 Offset: 0000332e"

I can compile the same script and use default icons fine.

The compilation works fine - default or specified icon if I replace the aut2exe.exe file from the beta release with the one from the current release version of autoit3 - and the generated exe seems to work ok when executed

Are you running aut2exe manually ?

What are the dates of the files aut2exe and AutoitSC.bin ?

What type of ICON filedo you use ? (can you attach one that creates this problem) ?


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Are you running aut2exe manually ?

What are the dates of the files aut2exe and AutoitSC.bin ?

What type of ICON filedo you use ? (can you attach one that creates this problem) ?

I have found I get the problem running aut2exe via the GUI interface and the command line

The dates of the files are :

Aut2exe :

version 3.0.102.0

Created : 08 September 2005, 07:52:50

Modified - 04 August 2004, 21:30:38

AutoitSC.bin

version3.1.1.111

Created : 08 September 2005

07:52:50, Modified - 03 March 2006, 18:53:34

I can cause the error using one of the icons supplied with the release version of AutoIt eg:

AutoIt_32x32x256.ico

Created - 08 September 2005, 07:52:50

Modified - 04 September 2003, 12:14:18

Whilst getting all this info I double checked the zip file for the beta autoit versions I have used recently - back to release 93 and can't see aut2exe.exe in any of them.

I think I must have left the old version of aut2exe from the 4 august 2004 release version of autoit in the directory as the version I am having trouble with is v3.0.102.0 whilst the version supplied with the latest release version of autoit which seems to be working and is a later version v3.1.1.0

Looks like I have gotten in a muddle with the files for aut2exe and that was my problem :)

I will recreate my install to confirm all other files are correct versions thus :

delete the current files

extract the latest release version zip into the directory

extract beta files over the top of this

Share this post


Link to post
Share on other sites

I don't know if you will succeed in using the .zip unless you are very experienced on the installation with it.

I will recommend you install the official release with the setup.exe and the same for the beta. :)

Share this post


Link to post
Share on other sites

TRansfert to support forum in case you want to follow the discussion. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0