Sign in to follow this  
Followers 0
Phil Viton

Checkbox Label Background

8 posts in this topic

Can someone tell me if this is the expected behavior? In the script below,

I set up a tabitem, and then put a checkbox onto it. When I run

the script, if the mouse goes over the text ("Append Results") , then the text background

changes to dark gray. (At least it does on my system: I'd be interested

to know if other don't get the same result). If I put the same control on a top-level form

(comment out the lines indicated by <---) this doesn't happen.

Not a big deal, of course, but I'm puzzled.

============== test.au3 ====================

#include <GUIConstants.au3>

$Form1 = GUICreate("Test", 450, 400, 192, 125)

$Tab1 = GUICtrlCreateTab(20, 30, 420, 350) ; <---

$intab = GUICtrlCreateTabItem("Input ") ; <---

$AddBox = GuiCtrlCreateCheckBox("Append Results",130,300,100,10)

GUICtrlSetState(-1, $GUI_CHECKED)

GUICtrlCreateTabitem ("") ; <---

GUISetState(@SW_SHOW)

While 1

$msg = GuiGetMsg()

If $msg = $GUI_EVENT_CLOSE then exit(0)

WEnd

============= end test.au3 ==============

Share this post


Link to post
Share on other sites



doesnt happen on mine

but here is an idea

#include <GUIConstants.au3>

$Form1 = GUICreate("Test", 450, 400, 192, 125)

$Tab1 = GUICtrlCreateTab(20, 30, 420, 350); <---
$intab = GUICtrlCreateTabItem("Input "); <---
$AddBox = GuiCtrlCreateCheckBox("Append Results",130,300,100,20)
 GUICtrlSetBkColor(-1, $GUI_BKCOLOR_TRANSPARENT); or pick a color
GUICtrlSetState(-1, $GUI_CHECKED)
GUICtrlCreateTabitem (""); <---

GUISetState(@SW_SHOW)
While 1
$msg = GuiGetMsg()
If $msg = $GUI_EVENT_CLOSE then exit(0)

WEnd

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

What version of AutoIt are you using Phil?


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

nice idea, but where is $GUI_BKCOLOR_TRANSPARENT defined? Inserting the statement into my code gives an error, and I can't find it among the AutoIt macros. What's its value?

Share this post


Link to post
Share on other sites

nice idea, but where is $GUI_BKCOLOR_TRANSPARENT defined? Inserting the statement into my code gives an error, and I can't find it among the AutoIt macros. What's its value?

Again... what version are you running?

Download the newest Beta in the Developers forum, very first post at the top. That definition ($GUI_BKCOLOR_TRANSPARENT) is in the GUIConstants.au3 file in the Beta I know for sure.


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

Again... what version are you running?

Download the newest Beta in the Developers forum, very first post at the top. That definition ($GUI_BKCOLOR_TRANSPARENT) is in the GUIConstants.au3 file in the Beta I know for sure.

3.1.1 : exe dated 08/07/2005 . I take it from previous comments that I need to get the beta for this constant to be available, right?

Share this post


Link to post
Share on other sites

yes

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0