Sign in to follow this  
Followers 0

Problems with VideoLan Object

3 posts in this topic

#1 ·  Posted (edited)

I'm not sure if this is a coding error by myself, an autoit issue, or a videolan issue.

I've been trying to get the videolan object working within my script and when calling methods like play() and others, I get ==> The requested action with this object has failed.:

I've tried a bunch of examples posted by the videolan team and its still causing the problem.

I have been working with other objects like quicktime and wmplayer without many issues, but the videolan plugin just doesnt seem to want to cooperate.

I am running the .111 beta (just about to check for updates)

Edit- updated to 113 and still getting same results.

Any help would be great, thanks.

Edited by Emerica

Share this post

Link to post
Share on other sites


Have you tried looking for a VBS example that does what you want to do?


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post

Link to post
Share on other sites

#3 ·  Posted (edited)

Just try loading the vlc object and try to get it to play a file.

My code is split up pretty bad as its setup for multiple players.

Posting would be bad, ill put together a example.

There are a couple properties which seem to work, MRL, versioninfo and AutoPlay seems to return -1, I can set it to 0 but not to 1. The rest seem to crash it. Yes I have tried as many examples as i could find. I've tried with and without parens, capitalization.

#include <GUIConstants.au3>
$Form1 = GUICreate("AForm1", 337, 305, 648, 46)
$vlc = ObjCreate("VideoLAN.VLCPlugin.1")
$vlc_ctrl = GUICtrlCreateObj($vlc, 8, 8, 320, 240)
GUICtrlCreateLabel("Version: " & $vlc.VersionInfo , 8, 280, 320, 17)
$Input1 = GUICtrlCreateInput("", 8, 256, 273, 21, -1, $WS_EX_CLIENTEDGE)
$Button1 = GUICtrlCreateButton("Load", 288, 256, 40, 20)
While 1
    $msg = GuiGetMsg()
    Case $msg = $GUI_EVENT_CLOSE
    Case $msg = $Button1
    ;$options = StringSplit("", "|");
    ;$vlc.addTarget("C:\test.mpeg", $options, 8, 1)
        MsgBox(0, 'title', $vlc.autoplay)
    Case Else
Edited by Emerica

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0