Sign in to follow this  
Followers 0

Script Not Working When Looping

2 posts in this topic

This is my second script and should be a no brainer but all I can think of is it is running too fast or a V2 issue.

win2000 on a p3 with 392mb ram

I have the Windows Address Book (WAB) with about 2200 addresses.

There are some groups under the Main Identity

Buddy has been adding new contacts under Main Identity and not under a group.

Now he has a few hundred contacts with no group attached.

I can write a script and run it from the Quick Launch toolbar one by one and is flawless

but when I go to loop it, it starts doing the keystrokes on the wrong part of the window pane.

using Repeat or Goto has the same result

I start by highlighting the top contact of the list in the right hand pane

Send,!{ENTER} gets properties for the contact

Send,{TAB 15}{RIGHT 5} the lazy way to get to the "other" tab

Send, !G this highlights the Group Membership box so I can focus on it and note if it's empty

Sleep,500 zzzzzz

Send,{ESCAPE} this closes the properties box for the contact

Send, {TAB} this is supposed to highlight(activate) the contact I just looked at

Send, {DOWN} this goes to the next contact in the list

the problem is the Main Identity folder on the left hand pane gets activated and

runs the script from there

when i put a

doitman: at the top and a

Goto,doitman at the bottom

Repeat, 100 and EndRepeat has the same result.

Oooooooo I just read up on SetKeyDelay. Hopefully that is the ticket.

Nope. <sigh>

Share this post

Link to post
Share on other sites

Don't bother.... I fixed it by using a

LeftClick, 760,360

As long as i don't highlight any addresses by left clicking in no mans land, it will focus attention on the proper window pane. This allows me to give it the down command to carry on.

Share this post

Link to post
Share on other sites
Sign in to follow this  
Followers 0