Sign in to follow this  
Followers 0
monte

Beta Has No Legacy Support?

11 posts in this topic

I've written quite a large script with 3.1.1 and it doesn't run corretly under beta. I have so many errors that I don't even want to look at it under beta. Is this going to be fixed when beta becomes stable?

Share this post


Link to post
Share on other sites



I've written quite a large script with 3.1.1 and it doesn't run corretly under beta. I have so many errors that I don't even want to look at it under beta. Is this going to be fixed when beta becomes stable?

As the beta progresses, it's our jobs as scripters/coders to keep up with them and their changes. As a V2 script will not run with V3, I would imagine, it would be up to someone (Member/Dev/Whom ever) to take the initiative to write a converter to the new proper syntaxes. Your best bet is just code in the latest Betas, then you will never have this concern.

There can't be that many "specific" errors that your getting??, the only one I can think off and is the underscore not having a space that throws errors for most. IMHO, it's in our best intrest to follow the Beta and it's progressions, and change/impliment what we must when we must to keep our own work stable. The beta is much more stable and with more options than the released 3.1.1 version anyway.

Good Luck With That...


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

I've written quite a large script with 3.1.1 and it doesn't run corretly under beta. I have so many errors that I don't even want to look at it under beta. Is this going to be fixed when beta becomes stable?

What kind of errors do you mean ? there shouldn't be that many ......

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

thanks smoke_n: I don't have any underscores in my code (which is just under 4k lines). I'm not looking forward to recoding as I have just finished it under 3.1.1. But, there are new features in beta that I'm looking forward to incorporating. Here's to scripting!!!

Share this post


Link to post
Share on other sites

Hold on there folks! It's been my uncompiled scripts that have been failing, the compiled ones work fine. That's somewhat of a relief, although after additions from beta, I'm wondering if I'll get compilation errors.....I'll let ya'll know.

Share this post


Link to post
Share on other sites

thanks smoke_n: I don't have any underscores in my code (which is just under 4k lines). I'm not looking forward to recoding as I have just finished it under 3.1.1. But, there are new features in beta that I'm looking forward to incorporating. Here's to scripting!!!

Yeah, big scripts aren't fun when you have to go a debugging, but... I always end up changing something to the better that I was too lazy to go in and do before anyway. I guess it's a double edged sword. I would like to know personally what errors you were getting though (purely out of curiousity).

P.S. Good luck with the compiled version :).


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

Hold on there folks! It's been my uncompiled scripts that have been failing, the compiled ones work fine. That's somewhat of a relief, although after additions from beta, I'm wondering if I'll get compilation errors.....I'll let ya'll know.

I cannot understand why it should be OK when compiling.

Your installation should be wrong unless when compiling you reference the standard release instead of the beta. :)

Edit: no chance to have the beta corrected if needed if we don't know what are the errors

Edited by jpm

Share this post


Link to post
Share on other sites

I cannot understand why it should be OK when compiling.

Your installation should be wrong unless when compiling you reference the standard release instead of the beta. :)

Edit: no chance to have the beta corrected if needed if we don't know what are the errors

jpm, I think monte is saying his compiled scripts (EXE files) still work. (Of course we know that EXE files are stand-alone and are not affected by what versions of AutoIt are installed on the computer!)

Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

Hold on there folks! It's been my uncompiled scripts that have been failing, the compiled ones work fine. That's somewhat of a relief, although after additions from beta, I'm wondering if I'll get compilation errors.....I'll let ya'll know.

I can't tell from your description if you are seeing the same thing, but I ran into problem of my own a couple months ago with Prod and Beta. The crux of the matter was that installing Beta (by default) overwrote the include files for Prod. All my scripts still worked, but only when run and compiled under Beta. :mellow:

Trying to run or compile anything under Prod caused errors because the overwritten include files tried to use Beta features not available under Prod.

Last I heard, the Gurus were considering changing the default behaviour of Beta to install completely in the Beta sub-folder, so as not to overwrite anything in Prod.

Anybody know if a decision was made on that? As of Beta 106, I think it was unchanged... :)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

#10 ·  Posted (edited)

I can't tell from your description if you are seeing the same thing, but I ran into problem of my own a couple months ago with Prod and Beta. The crux of the matter was that installing Beta (by default) overwrote the include files for Prod. All my scripts still worked, but only when run and compiled under Beta. :mellow:

Trying to run or compile anything under Prod caused errors because the overwritten include files tried to use Beta features not available under Prod.

Last I heard, the Gurus were considering changing the default behaviour of Beta to install completely in the Beta sub-folder, so as not to overwrite anything in Prod.

Anybody know if a decision was made on that? As of Beta 106, I think it was unchanged... :)

They fixed it. It was in the Developers Forum a while back.

http://www.autoitscript.com/forum/index.php?showtopic=23007

Edited by greenmachine

Share this post


Link to post
Share on other sites

They fixed it. It was in the Developers Forum a while back.

http://www.autoitscript.com/forum/index.php?showtopic=23007

Coolness, thanks! :)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0