Sign in to follow this  
Followers 0
jackyyll

Ie.au3 Help

2 posts in this topic

#1 ·  Posted (edited)

Hmm im trying to make a script that will goto http://imageshack.us, type in the upload box and then press host, but i cant seem to get it to type in the upload box.. heres my code

#include <IE.au3>

$IE = _IECreate()
_IENavigate($IE, "http://imageshack.us/iframe.php")
$form = _IEFormGetObjByIndex($IE, 0)
$input = _IEFormElementGetObjByName($form, "fileupload")
_IEFormElementSetValue($input, "your username here")

Exit

Also on another thought.. is it possible, to make something happen like.. say a msgbox popup when you click on a traytip?

Edited by jackyyll

Share this post


Link to post
Share on other sites



Hmm im trying to make a script that will goto http://imageshack.us, type in the upload box and then press host, but i cant seem to get it to type in the upload box.. heres my code

#include <IE.au3>

$IE = _IECreate()
_IENavigate($IE, "http://imageshack.us/iframe.php")
$form = _IEFormGetObjByIndex($IE, 0)
$input = _IEFormElementGetObjByName($form, "fileupload")
_IEFormElementSetValue($input, "your username here")

Exit

Also on another thought.. is it possible, to make something happen like.. say a msgbox popup when you click on a traytip?

INPUT TYPE=FILE elements are not scriptable for security reasons (a browser restriction). There is an example in reply 3 of the IE.au3 thread that shows how to work around this with a .focus method and the AutoIt SEND command.

Not sure what you mean by a "traytip".

Dale

p.s. Please edit your reply in the IE.au3 thread and insert a pointer to this post...


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0