Sign in to follow this  
Followers 0
Jamie1414

Mouse Movement Problems

4 posts in this topic

I am trying to make my program do something over and over and it was working fine so far but when i re-opened it it was missing the exact cords, even though the cordinates didn't change but the position of where the mouse moved changed. can some1 help me plz?

btw here is what kind of code im using for it...

MouseMove(394,274)
MouseDown("left")
MouseUp("left")
Sleep(1000)

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Well I can't exactly tell what you're saying, but I know that as long as you're using the same mouse coord mode with the same resolution monitor, it should stay the same.

Also, your script can be simplified to this:

MouseClick ("left", 394, 274)
Sleep (1000)

If you want it in a loop, here's an infinite loop:

While 1
    MouseClick ("left", 394, 274)
    Sleep (1000)
WEnd
Edited by greenmachine

Share this post


Link to post
Share on other sites

You may want to take a look at Opt('MouseCoordMode') in the help file.


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

Also look at WinWaitActive.......


[size="1"][font="Arial"].[u].[/u][/font][/size]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0